Always 0 stats

2004-10-01
2012-10-11
  • Nobody/Anonymous

    Guys, I need help before I loose my mind...
    I am new to AWStats and thid probably contributes to the cause of the problem but here goes.

    I have installed Apache 1.3 for Windows with no problems, installed Active Perl 5.8.4 again with no problems. During the installation of AWStats 6.1 I went through the wizard and saw no errors. It actually indicated that it has found the Apache installation and the conf files that go with it.

    I manually editted the AWSTATS conf file to match my settings, such as the log file location, log type etc etc. When I run AWStats with the following command line

    perl awstats.pl -config=servername-domainname.com -output -staticlinks > awstats.servername.domainname.com.html

    It produces the HTML file with all the sections in it but it is always 0. All counters are 0. No stats.

    Question is, where is this thing going wrong?

    The log files I am using are from different sources. I tried SMTP log files from IIS SMTP Service, Web Log files from the same IIS Service. And FTP log files from Microsoft FTP Server. None of them turn up any stats...

    HELP

    Thanks

     
    • Thorsten Franzke

      Now, having read of this for about the 10th time, I have test-run one of my domains with the staticlink setting (usually I do use the dynamic version).
      And, yes, I do have the same results. The only section where I am getting valid data is the 'monthly section' (probably due to the fact, that I had the statistics run dynamically before).

      So, at least you are not alone. However, would switching to dynamic page gen. help you? I personally do prefer this method.

      Best regards,

      tfranzke

       
    • Nobody/Anonymous

      Thanks Thorsten for you reply, relly appreciate it.

      Good to know I am not the only one... ;-)

      Anyway, as I am new to this tool I am not sure how to switch to Dynamic page gen. but while reading through the documentation I tried the switch to fill the database. I think this is what you mean? Am I right?

      Through this procedure I ran into a message telling me that the log format was incorrect set. I have changed this and now all the records are dropped.

      Well, at least the log file is examined... ;-) Do you maybe have any idea what is wrong with this?

       
      • Thorsten Franzke

        Well, if your log format was incorrectly set before and you have changed it and now all lines are dropped then this might be due to two things:

        a) You have switched to the wrong logformat

        b) You didn't delete/rename the database file before running awstats with the same logfiles again. Awstats will ignore logfiles that it has processes before and will also ignore logfiles that are older than the most current one's.

        Best regards,

        tfranzke

         

Log in to post a comment.