Premature end of script headers: awstats.pl (500 error) for SINGLE month only!

2012-11-12
2012-11-15
  • KevinMcCallum

    KevinMcCallum - 2012-11-12

    Receiving a "500 - Internal Server Error" when attempting to view a single particular month of stats for a domain URL that displays all other months just fine. And other domains work just fine for the problem month as well......so problem is limited to one particular SiteDomain for only one particular month of stats.

    IE:
    This works: http://x.x.x.x/cgi-bin/awstats.pl?month=09&year=2012&config=www.siteONE.com
    And this works: http://x.x.x.x/cgi-bin/awstats.pl?month=10&year=2012&config=www.siteTWO.com
    But this does NOT: http://x.x.x.x/cgi-bin/awstats.pl?month=10&year=2012&config=www.siteONE.com

    Why won't siteONE work for October (month=10)?? Error in the Apache log file is simply this: "Premature end of script headers: awstats.pl, referer: http://x.x.x.x/cgi-bin/awstats.pl?month=10&year=2012&config=www.siteONE.com"

    So since displaying of stats works for all other sites and all other months except for this one exact site/month combination.....the problem is most likely not with permissions on 'awstats.pl', or with perl or Apache permissions either. Seems like it must be something with that particular month's .txt stats file in the DirData. Can anyone suggest where else I might look, or what the problem with that stat file might be?? Any help or direction would be MUCH MUCH appreciated! Thank you,

    =Kevin.
    kevin.mccallum@marketlive.com

     
    • Albrecht Mueller

      Just an idea: October was a busy month on siteONE, so the AWStats process runs into some timeout which limits the time available for producing the html output.

      Albrecht

       
      • KevinMcCallum

        KevinMcCallum - 2012-11-13

        Yes, you're correct that October was an INCREDIBLY busy month for siteONE. By FAR their busiest ever with 4x number of visits than normal. So is there a setting somewhere that I can adjust to increase the timeout for producing the html output...??

         
        • Albrecht Mueller

          I think you have to configure the your web server accordingly, maybe the following link is helpful: http://httpd.apache.org/docs/current/en/mod/core.html#timeout

           
          Last edit: Albrecht Mueller 2012-11-14
          • KevinMcCallum

            KevinMcCallum - 2012-11-15

            Yep! That was it. Bumped up the 'TimeOut' in Apache and it looks good now. Can see all the stats for the site's best month ever. Thanks a ton for your help. Load off my mind...

             

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks