#123 Layer delivers wrong frame

v2.5x
closed-works-for-me
Internals (76)
5
2005-05-08
2004-09-28
Anonymous
No

Under some special circumstances, the Layer-filter
delivers not the first frame (when asked so), but the
last frame it delivered is again served.

I made the following script under Win2k / AviSynth
2.5.5 20040901 and opend it with VirtualDub.

#########
# A moving version clip is generated
# (see help 'Animate' for details)
# It is upsized to 720x576 and
# converted to RGB32
Version
ConvertToRGB32
Animate(0,149,"Crop",0,0,64,32,316,0,64,32)
BilinearResize(720,576)

# This line really should do nothing!
Layer(ResetMask,"add")
# But when Layer is asked for some frames
# in the middle of a clip, and then
# for the very first frame,
# it delivers the last middel frame
# it served just before, instead
# of the first frame

# This line shows the effect:
# It asks for a frame in the
# middle, then for the first
# frame, then for the next middle
# frame, a.s.o.
# But every odd frame shown isn't
# always the first frame
Interleave(last,Trim(0,-1).Loop)
###########

I hope I helped you in developing AviSynth.
Sorry for my crappy English.

Discussion

  • Nobody/Anonymous

    Logged In: NO

    'Mask' has the same behavior! Just replace the line
    >> Layer(...
    with this line
    >> Mask(Greyscale)
    This line shouldn't change the (visible) video, only the
    alpha channel, but it also mixes the first frame with some
    later frames.

    Maybe there is an error in caching or something, but these
    two functions must be involved: When using
    >> ResetMask
    for example, there is no problem (the first frame allways IS
    the first frame).

     
  • Ian Brabham

    Ian Brabham - 2005-05-08
    • status: open --> closed
     
  • Ian Brabham

    Ian Brabham - 2005-05-08
    • labels: 438411 --> Internals
    • milestone: --> v2.5x
    • assigned_to: nobody --> ianb1957
    • status: closed --> closed-works-for-me
     
  • Ian Brabham

    Ian Brabham - 2005-05-08

    Logged In: YES
    user_id=673887

    Cannot reproduce with latest 2.5.6

    Probably related to 1145123

    IanB

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks