Trying to compile on 64 bit CentOS 5.2 and getting desperate! Any help would be appreciated.

Starting with sources from cvs. After running autogen, I do

./configure --with-win32-path=/usr/lib/avifile-0.7/win32/ --cache-file=config.cache. That completes just fine (I'll be glad to show config.cache if it's helpful.)

Then, make dies with this:

In file included from ./../../libavutil/internal.h:35,
                 from ./../../libavutil/common.h:283,
                 from cavsdsp_mmx.c:25:
/usr/lib/gcc/x86_64-redhat-linux/4.1.2/include/stddef.h:152: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'typedef'

make[3]: *** [cavsdsp_mmx.lo] Error 1
make[3]: Leaving directory `/root/avifile/ffmpeg/libavcodec/x86'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/root/avifile/ffmpeg/libavcodec'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/avifile/ffmpeg'
make: *** [all-recursive] Error 1

I've tried this on a couple of machines with the same result. I'm stumped. If anyone has a suggestion or would like more info, I'll be happy to provide it.