Error line 133 and 399 in 2.5.1 Ubuntu

Help
Anonymous
2010-08-12
2013-05-29
  • Anonymous - 2010-08-12

    Hey, just have these errors when trying to run it from the terminal to test it.

    root@db:/# sh /mysql_backup.sh
    /mysql_backup.sh: 133: source: not found
    /mysql_backup.sh: 399: Syntax error: "(" unexpected

    Any ideas?

     
  • Anonymous - 2010-08-12

    Just to help, this is line 399:

    function get_debian_pw() {
    

    and this is line 133:

    fi

    (the end of the if statement).

     
  • tiezeman

    tiezeman - 2010-08-17

    I'm having the same problem.
    The first error relates to the end of the config section, which should be used if the external config-file doesn't exist. In my case the external file does exist, yet it still returns the "source: not found" message.

    The line 399 is probably connected to the config file not being read, resulting in an empty password in the function called at line 399.

    This problem doesn't go away when including the external config options into the main file.

     
  • tiezeman

    tiezeman - 2010-08-17

    Solved it; I remembered someting similar a while ago. /bin/sh isn't guaranteed to work as /bin/bash in Ubuntu, so in order to run this file without error, invoke it by bash:

    # bash automysqlbackup

    To have it executed in your cron folder, in which the files are typically called by /bin/sh, just create a file like this:

    #!/bin/sh
    bash /some_other_folder/automysqlbackup

    It worked for me, I hope it helps you.

     
  • Kani

    Kani - 2011-09-08

    Yes, this helped me today. Thanks much.

     
  • PittaGurneyi

    PittaGurneyi - 2011-09-09

    The syntax function function_name() {} is not POSIX compliant and is only handled by bash. Since there is no good reason to use the function keyword in front of the function name, I will remove it and add a new 2.5* version in the following days. Then at least this problem is gone.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks