Language characters are not recognized

Help
Majofa
2008-03-30
2013-05-29
  • Majofa

    Majofa - 2008-03-30

    Spanish characters are not being recognized by the backup.

    I get elección instead of elección and so on.

    How can I solve this problem ?

     
  • Anonymous - 2010-07-08

    I also have this issue - is it something that I can fix with configuration?

     
  • Johannes Kolter

    Johannes Kolter - 2010-07-08

    Can you post the complete error, please!
    Also make shure you're using the latest version.

     
  • Johannes Kolter

    Johannes Kolter - 2010-07-08

    This time I'm poking around with special caracters in names of databases. I thougt it was a good idea to consult the docs of the database-server-software: http://dev.mysql.com/doc/refman/5.1/en/charset-unicode.html.

    After doing so, I've decided to change my configuration as follows in the client-stanza of /etc/mysql/my.cnf:


    default-character-set = utf8

    IMHO it should be set to the charset of the operating system the server is running on.
    Since they are both communicating in utf8 I'm able to backup every database named with non-ascii characters.

    To check the default-configuration of a mysql client programm use:
    mysql -print-defaults
    mysqld -print-defaults
    mysqldump -print-defaults

     
  • Anonymous - 2010-08-02

    Problem solved - I changed all the tables to be utf-8_general _ci and everything worked ok. Previously they had been latin1 for some reason.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks