automysqlbackup v3.0_rc6 - error 1142

  • Mike Tarkowski

    Mike Tarkowski - 2012-12-17

    When I run automysqlbackup /etc/automysqlbackup/myserver.conf  get the following error.  I see a number of suggestions for adding a grep line but they appear to be solutions for older releases.  Does anyone know a soluiton for eliminating the error with the newer version automysqlbackup v3.0_rc6?

    Error message

    mysqldump: Got error: 1142: SELECT,LOCK TABL command denied to user 'root'@'localhost' for table 'cond_instances' when using LOCK TABLES
    du: WARNING: use -si, not -H; the meaning of the -H option will soon change to be the same as that of -dereference-args (-D)



  • fullmoonguru

    fullmoonguru - 2013-01-30

    This worked for me on Ubuntu server 12.04:

    in /etc/mysqlbackup/myserver.conf, find:

    # List of DBNAMES to EXLUCDE if DBNAMES is empty, i.e. ().
    #CONFIG_db_exclude=( 'information_schema' )

    and change to:

    # List of DBNAMES to EXLUCDE if DBNAMES is empty, i.e. (). 
    CONFIG_db_exclude=( 'performance_schema' 'information_schema' 'cond_instances' )

    Please note that I newb & this could result in some unforseen issue that I'm not aware of.  This answer referenced this page as the source:

  • Archana

    Archana - 2015-02-20

    CONFIG_db_exclude=( 'performance_schema' 'information_schema' 'cond_instances' )

    same worked for me on fedora

    Last edit: Archana 2015-02-20

Log in to post a comment.