mysqldump error 1556

  • kate matsuda

    kate matsuda - 2012-02-17

    mysqldump: Got error: 1556: You can't use locks with log tables. when using LOCK TABLES

    I'm getting this running the script on my databases.

    I guess ist does mean I have an outdated and presumably buggy version of mysqldump . Can anybody confirm this?
    MySQL is at version 5.1.45  however …

  • kate matsuda

    kate matsuda - 2012-02-20

    I solved this. Exclude the log tables from being dumped. Or just select only the databases you need instead of setting the parameter to "all". "All" means that also the log tables and the mysql database etc. get dumped. According to the MySQL manual this error message is not an error, because you should not use a lock on those tables.
    Sounds rather ill-logical to me, but anyway, you can work around this.

    The script could be improved a bit by automatically excluding the log tables as default when selecting "all" databases.  But you could do that by editing it yourself.

  • Chris

    Chris - 2012-08-03

    which logtables do you mean to exclude?

    I've just selected only the databases which i need. But i got the same error. I also try with 'all' and exclude 'mysql' and 'information_schema'.

    Is it possible to set mysqldump with the option '-lock-tables=0'?


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks