Customize path to xsl files

jpcapUser
2006-10-19
2013-04-09
  • jpcapUser

    jpcapUser - 2006-10-19

    Hello,

    i try to specify to Aurigadoc the files : xml2fo.xsl, xml2html.xsl, xml2man.xsl and xml2mhtml.xsl to customize them because some titles are in english and i want to internationalize them.

    I run Aurigadoc in command line.
    So i tried to put in the file aurigadoc.properties the line :
    xsl=E:\aurigadoc\test\xsl\pl, but it doesn't work.

    Then I tried to pass the path to the command line like :
    bash aurigadoc.sh -jhelp -XML E:\aurigadoc\test\bin\pl\help_pl.xml -OUT .\generated_pl -PARAM xsl=E:\aurigadoc\test\xsl\pl but it doesn't work more.

    In all the cases Aurigadoc loads files located on the root of AURIGADOC_HOME/test/xsl.

    I think my use of the option -PARAM and of the property file is wrong.
    Maybe is not possible to change the location where Aurigadoc searches the 4 files. I don't know !!

    I need some clue, any help will be kind.
    Thanks

     
    • Khurshidali Shaikh

      -PARAM xsl=.. should work and it shoud point to a xsl file NOT A FOLDER

       
    • jpcapUser

      jpcapUser - 2006-10-31

      Hello,

      it was what i tought.
      So is there a way to specify a path to ALL the xsl files ?

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks