8830 install problems

Help
David
2004-02-02
2004-02-29
  • David

    David - 2004-02-02

    I am using Ark Linux and I am having a problem trying to get aureal to install.

    I receive the following

    [root@localhost aureal]# make install
    cc -D__KERNEL__  -DMODULE -DAU8830 -mpentium  -O6 -fomit-frame-pointer -Wall -pipe -I/usr/src/linux/include   -c -o au_audio.o au_audio.c
    `-mpentium' is deprecated. Use `-march=pentium' or `-mcpu=pentium' instead.
    In file included from au_vortex.h:66,
                     from au_audio.c:49:
    /usr/include/linux/malloc.h:4:2: #error linux/malloc.h is deprecated, use linux/slab.h instead.
    au_audio.c: In function `set_data_format':
    au_audio.c:962: warning: deprecated use of label at end of compound statement
    make: *** [au_audio.o] Error 1

    Can anyone help me out?
    If you need more info or have a solution, please try to be detailed.  I am fairly new with Linux.

     
    • David

      David - 2004-02-03

      I was informed that installing the kernel source might be the problem... but now I get this.

      [root@localhost aureal]# make install
      cc -D__KERNEL__  -DMODULE -DAU8830 -mpentium  -O6 -fomit-frame-pointer -Wall -pipe -I/usr/src/linux/include   -c -o au_audio.o au_audio.c
      `-mpentium' is deprecated. Use `-march=pentium' or `-mcpu=pentium' instead.
      In file included from /usr/src/linux/include/linux/spinlock.h:7,
                       from /usr/src/linux/include/linux/module.h:11,
                       from au_vortex.h:58,
                       from au_audio.c:49:
      /usr/src/linux/include/asm/system.h: In function `__set_64bit_var':
      /usr/src/linux/include/asm/system.h:187: warning: dereferencing type-punned pointer will break strict-aliasing rules
      /usr/src/linux/include/asm/system.h:187: warning: dereferencing type-punned pointer will break strict-aliasing rules
      In file included from au_vortex.h:66,
                       from au_audio.c:49:
      /usr/src/linux/include/linux/malloc.h:4:2: #error linux/malloc.h is deprecated, use linux/slab.h instead.
      au_audio.c: In function `set_data_format':
      au_audio.c:962: warning: deprecated use of label at end of compound statement
      make: *** [au_audio.o] Error 1

       
    • Harshula Jayasuriya

      Hi,

      Firstly can you do a:

      uname -a

      and post the output.

      Secondly, which version of the driver are you using? There is a version 1.1.3.2 on jayasolutions.cjb.net, in the gnu/linux section. Please read the README first as it will probably address any questions you have.

      cya,
      #

       
    • David

      David - 2004-02-03

      1.  uname -a prints this...
      Linux localhost.localdomain 2.4.23-2ark #1 Mon Dec 1 16:06:17 UTC 2003 i686 i686 i386 GNU/Linux

      2.  I was using an older version then that one.  I downloaded that version and tried it.  I get this...

      [root@localhost au88xx-1.1.3.2]# make install
      ld -m elf_i386 -r au_audio.o au_core.o au_midi.o au_mixer.o au_sndstat.o au_utils.o au_vortex.o asp30-patched.o -o au8830.o
      mkdir -p /lib/modules/2.4.23-2ark/drivers/sound
      cp -f au88*.o /lib/modules/2.4.23-2ark/drivers/sound
      /sbin/depmod -a
      depmod: *** Unresolved symbols in /lib/modules/2.4.23-2ark/drivers/sound/au8830.o

      The readme file says that I should recompile the kernel, but I don't know how.

      I have also been reading about this ALSA stuff.  Does that support Aureal Vortex 2?  I had it installed but my sound didn't work at all.

       
    • Manuel Jander

      Manuel Jander - 2004-02-29

      You may try the ALSA driver...

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks