unresolved symbol snd_verbose_printk

Help
arctan1701
2003-11-23
2003-11-23
  • arctan1701

    arctan1701 - 2003-11-23

    i've been trying to get my vortex 2 card working with any of the drivers that are listed on this forum... while trying to use the alsa drivers, i get the following error:

    [root@localhost alsa-driver-0.9.8]# modprobe snd-au8830
    /lib/modules/2.4.22-10mdk/kernel/sound/acore/snd.o: unresolved symbol snd_verbose_printk
    modprobe: insmod /lib/modules/2.4.22-10mdk/kernel/sound/acore/snd.o failed
    modprobe: insmod snd-au8830 failed

    modprobe soundcore seems to work as does modprobe au8830 after editing gcc2 to gcc3. any ideas where my problem is?

    thanks

     
    • arctan1701

      arctan1701 - 2003-11-23

      hmmmm... even though i never got rid of the above errors, i seem to have sudio working. not sure how that happened.

       
    • Paul Hanly

      Paul Hanly - 2003-11-23

      you need to:
      1. ensure you are going to build the right alsa driver for the card. See which card you have by: lspci -v
      2. make uninstall
      3. make clean
      4. ensure the kernel-source is loaded: urpmi kernel source (in mandrake 9.1, if using other distro use rpm commands to try to install the package: kernel-source. You will either load it or be told it is already installed.
      5.  ensure sound is loaded: lsmod If sound core and sound don't appear in the list then: modprobe sound
      6. change the switches attached to your ./configure statement and ./configure (see:
      http://alsa.opensrc.org/index.php?page=au88x0\):
      EG:
      ./configure --with-cards=au8820 --with-sequencer=yes --disable-verbose-printk
      but use the 10 or 30 rather than 20 depending on which card you wish to make the driver for.
      7. follow the directions as per Quick Install as available from the link on the page above.
      8. use amixer (or alsamixergui if you have it) to unmute the soundcard and adjust both the main and PCM volumes.
      9. use: alsactl store to save the state of the muting and volumes so you don't have to do htis again each time you use it.
      10. adjust your /etc/modules.conf file as shown in the relevant link from the page above.
      11. adjust your /etc/modules so that sound and the driver load automatically if you only have one soundcard and just want to be able to start up and play a few MP3's using eg Noatun or similar.

      All of the info is available frm the page given above and the pages linked from it.

      Here is what worked for me, but read the cautionary statements and it appears to have a few conflicting directions but still worked for me:

      Please note you should verify all of the following yourself as it is simply a solution which worked for one newbie on one machine with particular linux, cars, alsa drivers and you follow these suggestions at your own risk. If you have more sophisticated setup (eg more than 1 soundcard) or more complicated needs, what follows may not be appropriate for you.

      Note: If you have kde 3.1 installed there are files you can test with for:
      midi: /usr/share/apps/kmid/
      mp3: /usr/share/apps/kbattleship/sounds/
      wav: /usr/share/sounds/

      If you just want to open eg Noatun and play an mp3 and you only have 1 soundcard there are 2 issues when rebooting after you have successfully installed the alsa drivers and devices and heard sound eg by playing midi and mp3s.

      1.  you don't want to have to reload all the modules manually and in the right order; and
      2. you don't want to have to open alsamixergui and unmute the master and PCM channels and adjust their volumes.

      Solution:

      1. Open /etc/modules as root and add all the modules that you installed using modprobe:
      sound (remember you had to have sound loaded before you started installing alsa-driver-0.9.8)
      snd-au8820 (or 10 or 30, depending on your soundcard)
      snd-pcm-oss
      snd-mixer-oss
      snd-seq-oss

      2. Once you have opened alsamixergui or otherwise set your unmuting and volumes, do command: alsactl --help You will see that if you do command: alsactl store you will save your values into a configuration file saved at /etc/asound.state  You may well be able to edit that file manually once it has been set up initially by: alsactl store

      3. Putting something like the following in your /etc/modules.conf file (in older installations this might be conf.modules):

      # ALSA portion
      alias snd-card-0 snd-interwave
      alias snd-card-1 snd-cmipci
      options snd-cmipci id="first" enable_midi="1"

      # OSS/Free portion - card #1
      alias sound-slot-0 snd-0
      alias sound-service-0-0 snd-mixer-oss
      alias sound-service-0-1 snd-seq-oss
      alias sound-service-0-3 snd-pcm-oss
      alias sound-service-0-8 snd-seq-oss
      alias sound-service-0-12 snd-pcm-oss

      Cheers
      Paul

       

Log in to post a comment.