No Sound - Any Help Appreciated

  • Chuck Benedict

    Chuck Benedict - 2004-01-20

    I have a Vortex 2 SQ2500 Gold PCI card connected to a Soekris 4501 embedded MOBO.  Pebble linux distro was installed.  Kernel was rebuilt with sound support compiled in.  Driver 1.1.3 was compiled on a RHL9 machine with a PIII.  Target 4501 is a 486.  After hacking the make file to target a 486 architecture and changing the include file location for the kernel source (target is running kernel version 2.4.22), driver compiled fine and was installed manually on embedded cf card.

    So far, so good.  Embedded board recognizes card.  Modprobe loads driver.  Here is config info...

    lspci says this:

    00:11.0 Multimedia audio controller: Aureal Semiconductor Vortex 2 (rev fa)
            Subsystem: Aureal Semiconductor AU8830 Vortex 3D Digital Audio Processor        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
            Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
            Latency: 60 (1000ns min, 3000ns max), cache line size 10
            Interrupt: pin A routed to IRQ 10
            Region 0: Memory at a0000000 (32-bit, non-prefetchable) [size=256K]
            Region 1: I/O ports at e000 [size=8]
            Region 2: I/O ports at e008 [size=8]
            Capabilities: [dc] Power Management version 1
                    Flags: PMEClk- DSI+ D1- D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                    Status: D0 PME-Enable- DSel=0 DScale=0 PME-

    Running modprobe au8830 gives this in dmesg:

    au88xx: Loading...
    au88xx: Found vortex PCI device:
    au88xx: id=0x0002
    au88xx: bar0=0xa0000000
    au88xx: irq=10
    au88xx: Add device, audio=3, mixer=0, midi=2

    Output from /dev/sndstat gives this:

    OSS/Free: 0x30802
    Load type: Driver loaded as a module
    Kernel: Linux pebble 2.4.22-pebble #3 Sun Jan 18 16:44:29 CST 2004 i486
    Config options: 0

    Installed drivers:
    Type 0: Aureal Vortex

    Card config:
    (AU8830 at 0xa0000000 irq 10)

    Audio devices:
    0: AU8830 (DUPLEX)

    Synth devices:
    Not supported by current driver

    Midi devices:
    0: AU8830

    0: System Clock

    0: AU8830

    So what could possibly be the problem you may ask?  No sound!

    I have tried a simple 'cat > /dev/audio' - nada.

    I have tried mpg123-oss-i486.  It appears to play an mp3.  Chews up 40% of the CPU.  Verbose output shows frames flying by.  No audio.

    Made sure aumix has volume turned up.

    Anyone have any ideas?  I am stuck.  Thanks ahead of time.

    • Geoff Field

      Geoff Field - 2004-01-20

      I know this sounds silly, and I apologise for asking it, but do you have the volume turned up at all?

    • Chuck Benedict

      Chuck Benedict - 2004-01-21

      Yes, I used aumix to turn up all output devices to 100%.  Speakers are plugged in and turned on.  I know someone had to ask.

      As an aside, I upgraded to the drivers to no avail.  Everything appears like it should work, but still no sound.  I'm pulling my hair out.

    • Manuel Jander

      Manuel Jander - 2004-02-01

      I would suggest trying the ALSA driver. It works much better than the OSS driver and supports more features (hardware EQ, SPDIF. more channels).

      Best Regards


Log in to post a comment.