AU8830 Problem

Help
Santiago
2003-12-04
2003-12-11
  • Santiago

    Santiago - 2003-12-04

    When I was trying to do the "make install" i got an error that said that many of the files were not found. I edited the Makefile and it appeared an error that i cannot compile multiple files with -c and -o.
    What should the include directory be like then?

    Can I use the ALSA drivers with the Montego II card. I tried using YaST specifying 2 Vortex drivers and they did not work.
    Thank you.

    PS. I downloaded the open sound drivers and work for 20 minutes only due to the trial limit.

     
    • Harshula Jayasuriya

      Hi,

      Could you please copy'n'paste the output you got, it's a bit hard to help you otherwise.

      You need to also tell us which version of the binary driver you are trying to install. Is it a 1.1.2 or 1.1.3.x.

      re: ALSA, I'm sure Manuel can help you with that, he should chime in soonish.

      cya,
      #

       
    • Santiago

      Santiago - 2003-12-05

      The version I am using is 1.1.2

      The error I receive when I run it with any of these commands:
      INCLUDEDIRS = -I/lib/modules/2.4.21-99-default/build/in
      or
      INCLUDEDIRS = -I/usr/src/linux/include
      or
      INCLUDEDIRS = -I/usr/include

      I get the following error, in addition to others:
      "You should not include /usr/include/{linux,asm}/ header
      files directly for the compilation of kernel modules.
      glibc now uses kernel header files from a well-defined
      working kernel version (as recommended by Linus Torvalds)
      These files are glibc internal and may not match the
      currently running kernel. They should only be
      included via other system header files - user space
      programs should not directly include <linux/*.h> or
      <asm/*.h> as well.

      To build kernel modules please do the following:

      o Have the kernel sources installed

      o Make sure that the symbolic link
      /lib/modules/`uname -r`/build exists and points to
      the matching kernel source directory
      o Configure kernel sources:
      - cd /usr/src/linux
      - make mrproper
      - make cloneconfig
      - make dep
      o When compiling, make sure to use the following
      compiler option to use the correct include files:

      -I/lib/modules/`uname -r`/build/include
      instead of
      -I/usr/include/linux
      Please adjust the Makefile accordingly."

      I also have a doubt that is not related to Aureal. I installed the printer drivers for an HP deskjet. After installing, it gives an error as if it could not communicate with the parallel port. What should I do?

      Thank you,
      Santiago

       
      • Harshula Jayasuriya

        Hi,

        You really have two choices.

        You can download the latest binary driver (1.1.3.2) from jayasolutions.cjb.net. I maintain these drivers in the openvortex project at savannah. It's just a newer version of the driver you just tried to install.

        Or you can try the ALSA driver whish is also developed and maintained in the openvortex project at savannah.  Paul Hanly has already referred to them.

        I suspect the former is going to be easier, however, there's no harm in trying both.

        cya,
        #

         
    • Paul Hanly

      Paul Hanly - 2003-12-05

      The main source of help for ALSA Aureal soundcard drivers is:
      http://alsa.opensrc.org/index.php?page=au88x0
      and the pages linked from it.

      A.   The main places to get drivers are:

      http://savannah.nongnu.org/projects/openvortex

      http://aureal.sourceforge.net

      http://alsa.opensrc.org and particularly http://alsa.opensrc.org/index.php?page=AlsaDrivers

      http://alsa-project.org/

      B.   There are discussion threads about drivers at:

      http://alsa-project.org/ (see the mailing list pages and search the archives)

      http://www.linuxquestions.org/questions/forumdisplay.php?s=&forumid=18

      http://www.mandrakeusers.org/index.php?showforum=9

      https://sourceforge.net/forum/forum.php?forum_id=25250

      You can search most of these on the website using your driver or card name or a word from the problem as your search word.

      C. Make sure you have read the INSTALL file in the unzipped tar.bz2 and that you have confirmed your card by doing (as root): lspci -v before you start doing. If you are installing alsa-drivers there is an old and somewhat out of date but sometimes helpful HOW-TO at:
      http://mirrors.kernel.org/LDP/HOWTO/Alsa-sound-2.html 

      E. General steps you might encounter, based on my experience with alsa-driver (http://alsa-project.org/) and aureal.sourceforge (http://aureal.sourceforge.net) and Openvortex (http://savannah.nongnu.org/projects/openvortex):

      Should you donwload cvs versions: this is a whole extra issue about how CVS works and whether you are using a gui under windows (eg because your winmodem doesn't work under Linux) or command line. With the windows one you login in one place from the menu bar and check out from another menu place. Sourceforge and Savannah both have instruction pages on using CVS both generally and for the particular project. the project CVS pages normally show the command line satements you need and they are adapted to use the winguicvs programs.

      Is sound support enabled?
      modprobe sound

      Are the kernel sources installed
      urpmi kernel-source (mandrake)
      rpm -q kernel-source (redhat)

      ./configure (you want to browse/ search the configure file looking for switches that you might need to use; they generally start with --). an example of a ./configure line for an alsa driver is:  ./configure --with-isapnp=no --with-sequencer=yes --with-oss=yes --with-cards=au8820 --disable-verbose-printk --with-debug=detect (the last two were attempts to overcome problems, the third last specifies which driver will be made -in the case of alsa-driver0.9.8 if you don't specify it makes all of them which takes an hour instaed of 12 minutes on my PII 400.

      You would need to change references to 8820 to 8830 if that is the chip for your card.

      make

      make install

      ./snddevices (if you are building alsa-drivers; see the page for your sound card at: http://alsa.opensrc.org/index.php?page=AlsaDrivers )

      modprobe <module name> (apparently recommended over insmod)

      Check for errors with depmod -ae even if everything seems successful.

      With Alsa you need to unmute and set volumes at greater than 0 (the default values) using amixer or alsamixergui.

      F. Some known problems

      Some alsa-driver0.9.8 files need patching:
      http://www.mail-archive.com/alsa-devel@lists.sourceforge.net/msg09813.html

      Some aureal drivers need patching:
      http://sourceforge.net/forum/message.php?msg_id=2156304 (but beware the popups if you go to his site)

      some make problems with /sbin/lspci: Command not found: See
      http://sourceforge.net/forum/message.php?msg_id=2011662

       
    • Santiago

      Santiago - 2003-12-10

      I already downloaded the files. HOwever, I need help installing the kernel sources. I tried searching with YaST (SuSE 9.0) 'kernel-source', but it did not return anything. Are the kernel sources included in the 3 CD's?
      If not, where could I download them from?

      Thank you very much.
      Santiago

       
    • Manuel Jander

      Manuel Jander - 2003-12-11

      Hi,

      AFAIK, SuSE doesn't provide any usable kernel headers. It only provides an unconfigured kernel source, which version tag usually doesn't match the running kernel causing a very lot of problems.

      If anyone knows a fix for this on SuSE, would be really great.

      The solution that i took on SuSE 8.0 (i'm NOT a SuSE user) was to install the kernel source from the CD's with YaST, copy the current config /boot/config-x.y to the kernel dir /usr/src/linux-x.y and patch the version info in modversions.h and version.h files... not something i would recommend to do to a newbie.

      By the way, don't even try to upgrade any version of SuSE to SuSE 9.0. Make a new install from scratch because if not, you'll may get sick (as i got today...)

      Best Regards

       

Log in to post a comment.