Project dead?

2002-03-21
2002-09-01
  • Jee Desjardins

    Jee Desjardins - 2002-03-21

    There's no more dev. done, at least I don't get anything new via the CVS, and from what I see, no post from any developper. I haven't checked the RE progress so don't know if someone worked on it recently.

    Could it be possible to have a reply from a developper just to know someone's still alive?

     
    • Jeff Muizelaar

      Jeff Muizelaar - 2002-03-21

      I am still here and still working slowly on the reverse engineering. I don't have cvs commit for this project anymore so I can't update anything.

      -Vizard

       
      • Jee Desjardins

        Jee Desjardins - 2002-03-21

        Nice to hear you vizard! I really hoped that someone was still working on this project. I'm currently trying to learn how the open-source part of the drivers work [I don't have any experience with drivers coding]. Then I'll try to slowly move to RE too.. maybe I will be able to help you all soon :)

         
      • Anonymous Person

        Good to hear from your Vizard!
        I haven't really got much better at ASM, but if you get a really basic driver going I'd like to have a play around with that, although I can't exactly extended it because I need to know the functions in the binary.

        Anyways. Great Stuff!

        Cheers,
        Grant

         
    • Anonymous - 2002-04-06

      I tried CVS and got nothing but "could not find module etc.....  When I looked at CVSROOT,  I couldn't see any of the aureal driver files. 

       
    • Jeff Muizelaar

      Jeff Muizelaar - 2002-04-06

      Anonymous CVS Access

      This project's SourceForge CVS repository can be checked out through anonymous (pserver) CVS with the following instruction set. The module you wish to check out must be specified as the modulename. When prompted for a password for anonymous, simply press the Enter key.

      cvs -d:pserver:anonymous@cvs.aureal.sourceforge.net:/cvsroot/aureal login

      cvs -z3 -d:pserver:anonymous@cvs.aureal.sourceforge.net:/cvsroot/aureal co modulename

      Updates from within the module's directory do not need the -d parameter.

      use 'aureal' as the modulename

       
    • Scott Robinson

      Scott Robinson - 2002-04-08

      What happened to the project admins? If you're still working on the drivers, is there any way they could give you CVS access?

       
    • Derek Foreman

      Derek Foreman - 2002-04-22

      Not quite dead yet.

      just sort of hibernating.

      I just committed some changes that will let it compile against 2.5.8

      hopefully I didn't break it for 2.4.x :)

       
    • Anonymous - 2002-05-22

      hi, i'm not happy reading this thread. I'm sorry that I dont have any skill creating drivers... so I cant help

      I've just get the CVS version, and compiled it, but it wont work :( i ddont have the log now, but the modprobe au8830 says: the module was compiled for 2.4.x kernel, but i've only 2.2.18 (so maybe it's working with 2.5 but not with 2.2 :)
      the release is working for me of course, but i don't want to change my kernel to 2.4.x only for my soundcard driver...

      my question is: what is cool in the CVS versions, what are the differences: i mean for me the last release was stable, there were small stops using with mplayer, but it was quite useful, so what will I win, when I'll use the CVS version??

      thx all the work for guys!!
      by

         Kukocs

       
      • Derek Foreman

        Derek Foreman - 2002-05-22

        That's not a bug I'm aware of.

        sounds like you've got the wrong kernel source tree in /usr/src/linux...

        (head /usr/src/linux/Makefile should confirm that)

        The module should have failed to compile entirely if something was broken against 2.2.x

         
    • Anonymous - 2002-05-23

      of course there is no 2.4.x kernel src in my kernel-src dir, but as I can remember, first time, when i tried to compile, it doesn't compile becouse my sys was lack in modversions.h I just copied that file from /usr/src/linux/include/linux to /usr/include/linux

      and after that i was able to compile the sources.
      I dont have ANY 2.4.x sources at all in my computer :) - but just want to know, is it worth to use the CVS version??

      by:
           Kukocs

      ps:  thx for your answer

       
      • Walther Zwart

        Walther Zwart - 2002-08-27

        To Kukocs:

        For me there was a big advantage. I have an au8820 and in 1.1.2 there is a bug that makes the kde-soundserver crash.
        Take a look at the cvs-changelog. If there is nothing there that you like, stick with 1.1.2.

         
    • Ryan Grange

      Ryan Grange - 2002-06-22

      Manmowerx, were those changes commited to the aureal_re or aureal branch?  I just tried to insmod the au8820 driver and the system had a fit about unresolved symbols.  (Mandrake 8.2, 2.4.18 kernel.)

       
    • Derek Foreman

      Derek Foreman - 2002-06-22

      the aureal branch

      What symbols are unresolved?

       
    • Manuel Jander

      Manuel Jander - 2002-08-05

      I'm on the way of integrating the gameport driver (linus kernel tree) into the sound driver (aureal project).

      By the way i discovered some "fixme" comments
      on the MPU401 support. I'm very tempted to fix that.
      I have 2 x Au8820, so i encountered some multiple sound board problems with the /dev/audio sun device.

      In several parts i missed some way to enumerate the Aureal boards. Is there some "card counter" somewhere ? if no i'll have to create one, because i really need it to fix the MPU401 and gameport.

      Greetz

      Bye.

       
    • Rod.Kapitzke

      Rod.Kapitzke - 2002-09-01

      Hey guy's (speeking as a newbie) I was just wondering how it is that Redmond linux (now Lycoris) recognises my au8830 based card and provides a driver during the OS's install. The kernel version is 2..4.12-4 what driver are they using (must be specific to that distro I guess).

       

Log in to post a comment.