Cant seem to install the driver, why?

2002-06-30
2002-08-18
  • Dixit Suthar

    Dixit Suthar - 2002-06-30

    I have tried to do the "make install" on my RedHat 7.3 and it seems to keep failing.  Please realize that I am a Linux newbie also.

    Is this because this driver wont work? Or do I need to do something different.

    Thanks
    Dixit

    The error it gives is

    cc -D__KERNEL__  -DMODULE -DAU8830 -mpentium  -06 -fomit-frame-pointer -Wall -pipe -I/usr/src/linux/include    -c -o au_audio.c
    make: cc: Command not found
    make: *** [au_audio.o] Error 127

     
    • Anonymous - 2002-07-05

      sounds like you need to install a compiler.

      try installing the GCC rpm.

      also, make sure you have the kernel-sources rpm installed.

       
    • Dixit Suthar

      Dixit Suthar - 2002-08-06

      I tried to run the install again after making sure I had installed the GCC and kernal-sources rpms.  I actually re-built this computer as a server now with all the latest updates from RHN.

      Now when I run make install, I get probably over 300 lines that flash by and it seems like it still dont install.  It comes up with alot of programming errors like "case label not within a switch statement"

      I wish I knew how to copy and paste what I see here, but dont know how.  When I tried to pipe it to a file, I only got two lines on the file.  Something did not work.

      I really want to get this soundcard working.

      Please help
      Dixit

       
    • Kevin Alm

      Kevin Alm - 2002-08-10

      It's fairly eazy to save the error messages if you do the install in an xterm in x. Use the scroll button to go up to the start of the text you want to copy. The left click hold and drag over the xterm text. Don't release until the text you want is highlighted. Without clicking again in the xterm window, left click in a editor, kate or gedit for example. Right click and paste.

       
    • Dixit Suthar

      Dixit Suthar - 2002-08-13

      I did what Kevin Alm said and it doesnt past anything.  I highlighted what I wanted in the gnome terminal emulation window and then left clicked into the gedit, still seeing that my selection is highlighted in the terminal window, right click and paste and it did nothing.

      Dixit

       
    • Kevin Alm

      Kevin Alm - 2002-08-13

      Sorry about that. I normally use KDE. This does work in the Gnome desktop, provided konsole is on your system.

      Use the kde default terminal konsole. (There may be a kde submenu in your gnome menu. Otherwise, select run from the menu and type in  konsole . Hopefully it's there somewhere.)

      Use gedit for editor.

      Select text and paste as I described before.

      I didn't realize this only works for the kde terminal  konsole. It must have an integrated "clipboard" of sorts.

      Hope this helps. Kevin

       
    • Dixit Suthar

      Dixit Suthar - 2002-08-15

      Thanks for helping me out on that part Kevin.  Now I did not want to copy and paste the some 400+ lines of error I see.

      The text file is located at
      http://mywebpages.comcast.net/dsuthar/error.txt

      Please let me know what I need to do from here.  I get the same lines of error on my other PC that also has the same sound card.

      Dixit

       
    • Kevin Alm

      Kevin Alm - 2002-08-15

      Wow! You did get a lot of errors. It looks like there are still some needed rpms missing on your system. Or possibly some that need updating.

      The first thing I would try is installing the kernel-source-(yourkernelversion).i386.rpm. This rpm is needed to compile this driver on all i386-686. Also, be sure to use the cvs and not one of the downloads. If you still have problems you may need to apply some or all of the glibc, gcc, and kernel errata that RH has issued.

      Good luck and let us hear how it goes. Kevin

       
    • Dixit Suthar

      Dixit Suthar - 2002-08-18

      Well I made sure I have the kernel 2.4.18-5 installed as well made sure I have the kernel-source 2.4.18-5 installed as well.  The kernel was installed through RedHat's update, I then downoaded the kernel-soruce rpm and installed it through GnoRPM. 

      Still getting the same set of errors.  I also have all the latest GCC compilers and GLIBC.

      Where am I going wrong?

       
    • Kevin Alm

      Kevin Alm - 2002-08-18

      Strange. You might check to see if these two synlinks are in order:

      /usr/src/linux2.4 >/usr/src/linux-2.4.18-x (x= your rev #)

      and

      /lib/modules/2.4.18-x/build > /usr/src/linux-2.4.18-x

      Your problem looks like something still isn't installed right, most likely kernel headers. These are supposed to be installed by kernel-source-2.4.18-5.i386.rpm in your case. Do you know how to force an rpm install at the command line?

      From within the directory containing the rpm type:

      rpm -Uvh --force kernel-source-2.4.18-5.i386.rpm

      This will force a fresh install of the specified rpm. It is a little drastic but OK if your carefull.

      One other thought. I have seen suggested in other threads that you should edit the Makefile and change the Include directories. This worked for some of the earlier driver releases but should NOT be done with the cvs. And you should use the cvs.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks