open Source Driver underway...

2003-02-26
2003-05-08
1 2 > >> (Page 1 of 2)
  • Manuel Jander

    Manuel Jander - 2003-02-26

    Hi everyone!

    I have really good news. I was able to make the mixer and SRC of an Aureal Vortex 8820 to work !! That means all the necesary stuff for a replacement driver is  there.
    Now i'm applying some cosmetics to the code and i'll upload to the CVS on savannah next week.

    By the way i started the design of a ALSA driver for the AU8820. I dissembled the windows drivers too, to tatke a look at the EQ and A3D stuff, but my windowss disassembler tools aren't that good like the ol' pal dasm.pl script.

    Unfortunately i dont own a 8810 nor 8830, so i cant port my stuff to this cards. If anyone would sell me one of these maybe i could :)

    Greetz

    mjander

     
    • Kristian Söderholm

      That's one of the greatest news I've heard for a long time.
      I just want to thank you and the rest of the developers for working
      with this driver!

      Now there's just one more thing I'm waiting for and that's that the
      driver will become 2.5.53+ compatible.

      Thanks again!
      /Kristian

       
    • Jeff Muizelaar

      Jeff Muizelaar - 2003-02-26

      I will probably take care of the au8830 port this weekend. The au8810 is really similar (just spec'd down a bit and without a3d) so it should be easy to go from the au8830 to the au8810.

      Zerobash: Unless someone else steps up to do the job I wouldn't count on the binary driver being 2.5.53+ compatible anytime soon. It is a mess and not really worth the time to port it.

      mjander: Have you put much thought into what all needs to happen for recording support?

       
      • Jeff Muizelaar

        Jeff Muizelaar - 2003-03-02

        Turns out I wont get the port done this weekend. Some capacitors blew on my motherboard and fried my cpu.
        I'll have to see how the rest of the week pans out.

        -Jeff

         
      • Derek Foreman

        Derek Foreman - 2003-03-20

        Wasn't all that hard to port.

        I have every intention of keeping this driver in a usable state until openvortex can replace it.

        I'm very much looking forward to that day. :)

         
    • Manuel Jander

      Manuel Jander - 2003-03-04

      What a mess! why in the world just your motherboard, one of the most important, one the few mainboards that do something worthy had to blew up  ??!

      :-)  just a joke.

      Regardind  the recording support, we  should start routing the audio backwards (thats whats done by the binary driver in first place).  after that, i have some flags in mind to play with.

      My last college year begun,  and know i have only one 1/2 of my spare time for the driver stuff, but it keeps making progress. This weekend ill update the  CVS.

      Best Regards.

      mjander

       
      • Jeff Muizelaar

        Jeff Muizelaar - 2003-03-05

        Well the capacitors are supposed to be delivered tomorrow so I should be up by tomorrow night, as long as the motherboard behaves and doesn't blow another cpu.
        I am away this weekend but I have a significant amount of travel time and my laptop is back to life now (hard drive died last week...) so I should be able to at least do a code merge (and maybe merge your cleanups later in the weekend).
        Fortunatly the code you wrote looks more portable than my driver was originally so as long as things are close it shouldn't be too bad. If nothing comes up I should have a decent amount of time the weekend after.

        -Jeff

         
    • Mike Everidge

      Mike Everidge - 2003-03-22

      Where's openvortex?

       
    • Manuel Jander

      Manuel Jander - 2003-03-22

      OpenVortex is at:
      http://savannah.nongnu.org/projects/openvortex/

      But the ALSA patches for AU8820 can be found at
      (still no recording support, but support upto 8 streams and MPU401 sequencer) :

      http://docencia.mat.utfsm.cl/~mjander/aureal/

      Best Regards
      Manuel Jander

       
    • Anonymous Person

      This is excellent news!  Good work!

      I have an au8830 card, is the driver usable for playing music ;) ?

       
    • Manuel Jander

      Manuel Jander - 2003-04-08

      Not yet. I'm working on it. The current ALSA patch supports AU8820 only. A few days ago i got a AU8830, so now i can add support for it. I guess that in about 2 weeks it could be done (at least a first beta release).

      By the way, recording works now on the AU8820 :), so it should on the AU8830 too, onces its supported.

      Best Regards

      Manuel Jander

       
    • Manuel Jander

      Manuel Jander - 2003-04-15

      SUpport for the AU8830 has begun to work.
      It still has some bugs (chip n' dale effect),
      but if you want to try ...

      mjander

       
      • tulevik

        tulevik - 2003-04-15

        may we hope  also support for the au8810 in the next future?

         
        • Jeff Muizelaar

          Jeff Muizelaar - 2003-04-16

          yep probably, unfortunatly no developers have the hardware so it could be slow going.

          -Jeff

           
          • Philipp Hahn

            Philipp Hahn - 2003-04-16

            My notebook has a builtin 8810 and so I'm stuck with that.
            If you need someone for testing, mail me. A ssh login should be no problem. If you need to put your hands on the hardware I'm willing too lend you my notebook for some time. (europe only, preferable germany)

             
    • SegV

      SegV - 2003-04-15

      Thanks/Gracias Manuel

       
    • Patrick Boutilier

      Having trouble with the ALSA drivers. Applied the patch-au88x0-0.92c patch and then ran autoconf and /configure --with-cards=au8830.

      After running make the module doesn't get created. Am I missing a step?

       
    • Manuel Jander

      Manuel Jander - 2003-04-18

      you need to do the following:

      aclocal
      autoconf
      ./configure --with-cards=au8830  [....]
      make
      make install

      That should work.
      The file "toplevel.config" should contain a line like
      CONFIG_SND_AU8830="m"
      If that line is present, the driver should get build.

      Regarding the AU8810 issue, a friend has a AU8810 on his notebook, so there is a chance :)

      Bye.

      Manuel Jander

       
      • Julio César Gázquez

        Manuel! Thanks!!! This really works!
        However, it seems to be messing with my ISA NE2000 compatible card. Conectivity dies when snd-au8820 driver is loaded. I guess shouldn't be conflicts (AUs are far from using io=0x300 and irq=3, aren't they?).
        Any idea?
        I still didn't do so much further tests, as the NE2000 driver in built into the kernel.

         
    • Manuel Jander

      Manuel Jander - 2003-04-20

      Regarding the AU8830... there was a bug. The good news: it isnt anymore there :)

      Get the latest ALSA patch ...

      Bye.

       
    • Slava Pankov

      Slava Pankov - 2003-04-23

      I have strange problem. KMix allows to raise sound only to 31%. It's maximum. Could you give me any advice please ? I'm using Mandrake 9.1 and KDE 3.1. Also ALSA interferes some way with ATI 2.9.6 video driver. I have corruption artifacts around the screen. But looks like it's ATI problem.

       
    • Manuel Jander

      Manuel Jander - 2003-04-24

      What driver are you using ? what kernel (2.2, 2.4, 2.5, ..) ?
      Need more info to help.

       
    • andrea biardi

      andrea biardi - 2003-04-24

      Hi,
      and thanks for your good work.

      I have a laptop with an aureal 8810 card available for testing / developing; also have a permanent fast (10mb/s) connection, if developers need.

       
    • Slava Pankov

      Slava Pankov - 2003-04-24

      Ok, it's additional info.
      I've downloaded ALSA from openvortex:
      cvs -z3 -d:pserver:anoncvs@subversions.gnu.org:/cvsroot/openvortex co alsa
      after that applied patch-au88x0-0.92e
      and made ./configure --with-cards=au8830
      my kernel is 2.4.21-0.13mdk and KDE 3.1
      I'm not sure about /etc/modules.conf in which I added manually
      alias sound snd-au8830
      alias midi  snd-au8830
      Is these two lines enough ?

       
    • Julio César Gázquez

      Hi. I did some further research. The connectivity is lost because the ethernet card doesn't receive frames. I found this first using tcpdump and loading the snd-au8820 module, then I look in the logs:

      May  3 16:43:10 kat kernel: Vortex: hardware init.... done.
      May  3 16:43:10 kat kernel: ALSA ../../alsa-kernel/pci/ac97/ac97_codec.c:2011: AC'97 0:0 analog subsections not ready
      May  3 16:43:10 kat kernel: eth0: mismatched read page pointers  0 vs 64.
      May  3 16:43:10 kat kernel: eth0: mismatched read page pointers  0 vs  1.
      May  3 16:43:41 kat last message repeated 278 times

      This message is emitted in the ei_receive() function, in the 8390.c file in the kernel. I have no familiarity with kernel code, but I guess you could be messing the 8390 driver memory, or it can be a locking problem, as ei_receive() must be called with some lock (the infamous big one?) held.

       
1 2 > >> (Page 1 of 2)

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks