Game port support is working !

2002-10-23
2002-11-19
  • Manuel Jander

    Manuel Jander - 2002-10-23

    Hi,

    I merged the "pcigame" driver of the vanilla linux kernel into the aureal driver, and it worked fine for me. I don't know if the Aureal Advantage could work (not enabled ... missing data).
    Where can i upload it ?
    The changes to the original driver are very small.
    I'll try to make it avaiable to

    http://docencia.mat.utfsm.cl/~mjander/aureal/

    ... in a few minutes.
    The next thing i would like to do is to add a /dev/sequencer device for the MIDI output (the MPU 401 UART), because many MIDI sequencers i tried don't work with the barebones /dev/midi device.

    This is my very first Linux kernel contribution. I hope you don't have to puke when reading the source :-)

    Bye.

     
    • Anonymous - 2002-11-19

      I compiled the driver fine... and I can load it via 'insmod au8830', but not 'modprobe au8830'. After modprobe, the system just sorta sits there... I can type, but it doesn't return a prompt. I can return to the prompt, but only after a CTRL-C.

      However, jstest /dev/js0 still reports "no such device." I do have the sidewinder module loaded.

      If I 'rmmod au8830' and 'insmod pcigame' (I did build the pcigame module, then with it compiled into the kernel, and then without it completely), I can use the joystick... I have gotten it working. Once I load au8830, I can't load pcigame, and I get the 'no such device' error.

      I'm running the 2.4.19 kernel, with a Diamond MX300 (AU8830), and a Microsoft Sidewinder Forcefeedback Pro Version 1 (sidewinder)

       
    • Anonymous - 2002-11-19

      Simple fix. Don't load the pcigame module... load the ns558 module instead... the generic gameport.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks