On 29 December 2013 14:06, Richard Ash <richard@audacityteam.org> wrote:
On Sat, 28 Dec 2013 22:24:12 +0000
Steve the Fiddle <stevethefiddle@gmail.com> wrote:

> On 28 December 2013 20:22, Richard Ash <richard@audacityteam.org>
> wrote:
> > On Sat, 28 Dec 2013 15:05:37 +0000
> > Steve the Fiddle <stevethefiddle@gmail.com> wrote:
> >
> >> Thanks Richard but it's still not building for me.
> >>
> >> With a fresh checkout of revision 13008:
> > (you don't actually need main AUdacity built at all, just a set of
> > sources, probably configured (although right now nothing depends on
> > configure options yet)).
> >
> >> cd lib-src/mod-nyq-bench
> >> manually change /lib-src/mod-nyq-bench/Makefile line 9 to the base
> >> of the Audacity source.
> > What exactly did you put in the file here?
>
>
> I checkout from svn with:
> svn checkout  http://audacity.googlecode.com/svn/audacity-src/trunk/
> audacity
>
> so normally I would put:
> AUDACITY_DIR ?=/home/steve/sourcecode/audacity/
>
> but I also tried:
> AUDACITY_DIR ?=/home/steve/sourcecode/audacity
> AUDACITY_DIR ?=/home/steve/sourcecode/audacity/src
> and
> AUDACITY_DIR ?=/home/steve/sourcecode/audacity/src/
> all of which produced the same error.

Remember that ?= assignment only assigns the value if AUDACITY_DIR was
previously undefined. I think you must have it set (probably to an
empty string, which still counts) elsewhere in the file or in your
environment.
(see end of
http://www.gnu.org/software/make/manual/html_node/Flavors.html)

> Thanks to your tip I've now found that it builds with either:
> AUDACITY_DIR=/home/steve/sourcecode/audacity/
> or
> AUDACITY_DIR=../../
This syntax over-rides any previous setting of AUDACITY_DIR in the
Makefile, so will work regardless of other assignments.

> I now have a problem that the module does not load.
> The Audacity log shows:
>
> Error: /home/steve/.audacity-files/modules/mod-nyq-bench.so: undefined
> symbol: gAudioIO
That's nothing to do with the build system, but it does happen as well.
I don't know why - it looks like it works the same way as gPrefs, and
we don't get an error about that (or does it just look for gAudioIO
first?). Not sure why this has broken, it doesn't look build system
related.

I've narrowed down when the break occurred.

As mentioned previously, r12960 Nyquist Workbench builds and works correctly.

r12861 I was unable to build Audacity.

r12962 Audacity will build and Nyquist Workbench, with the patch bug_mod-nyq-bench_build_fix.patch will build, but Nyquist Workbench fails to load. The error reported in the log is:
Error: /home/steve/.audacity-files/modules/mod-nyq-bench.so: undefined symbol: gAudioIO
so whatever the reason, the breakage occurred in 12961 or 12962,

Steve

 

Richard