HI,
  I wanted to thank everyone who contributes on this list as it has helped me a lot over the years.

I wanted to share a little problem I have come across.

I have a Windows XP Pro Dell laptop running either Audacity 1.2.6 or Beta version at different times.  I have a Alesis Multimix 16 firewire, 12 firewire and 8 USB 2.0

I initially struggled to get the firewire mixers to do multitrack mixing in either version of Audacity but after much web research found a sequence of driver and firmware updates that allowed me to get it to work.  (Anyone else stuck on this please let me know so I can spare you the headaches)  The odd thing is that on either the 12 track or the 16 track, for some reason I can only get 8 tracks possible in the Audacity dropdown box (preferences, devices, recording channels) 

I then tried Audacity and the same 2 firewire mixers on my Dell desktop that has Win 7 64 bit and an ASUS netbook that had the same Win 7 operating system.  I tried both versions of Audacity again and now the mixers show up in the preferences / devices as 'Microphone (2-Alesis Firewire'  I'm not sure where the left facing parentheses went to..  In addition I now only get the option for 2 channels of recording.

I'm using latest firmware and latest Win 7 drivers from Alesis.  If I use the Firewire mixers on Win 7 in Cubase or Reaper I can properly control all the individual channels.

SO if the Alesis firewire mixers work with Audacity in XP but not in Win 7 is this a problem with the Alesis drivers for Win 7 or is the 'limited support for Win 7' notation on the audacity web page hold the clue for why I lose my other channels?

It was my understanding that I needed ASIO driver support and somehow in the XP drivers this was included?  I looked at the install files for XP and Win 7 and can't really make out the difference.  There clearly is a Alesis ASIO driver included for both XP and Win7 provided by the manufacturer, so why can't Audacity use the ASIO support in Win 7?

By the way, all of the Win 7 systems I tried, the USB 2.0 8 channel Multimix won't give me more than 2 channels either which makes me wonder if it is an Audacity problem with Windows 7 and not the fault of Alesis.  The Alesis USB drivers for Win 7 are set up different than the firewire, they are called a 'usb microphone' in the Audacity dropdown which is an odd description for a mixer..

IF this is a problem with the fledling win 7 support for ASIO drivers supplied by manufacturers, are there any ways I can help test this Alesis provided driver with the Audacity support crew or does anyone else have success with Win 7 and Alesis USB or Firewire drivers?

Thanks in advance!
Jeff