4.1 installed but won't open

Help
2012-11-07
2013-04-20
  • David Monarchi

    David Monarchi - 2012-11-07

    System: Win 7 Pro x64; 2 x ATI Radeon HD 4850

    I have successfully installed 4.1 on a colleague's machine, but am encountering a strange problem on my own.  After installing 4.1, it refuses to open.  There are no error messages, and there are no processes listed as running.  When I click on the link, the cursor changes to a circling symbol for about 5 seconds and then disappears.  After that, nothing.

    I have 3.8 installed also, and it runs fine.  I have properly defined the path for Python, although I'm not getting any indication that this is the problem.

    If anyone could give me some pointers, I would be happy to provide more information.  At the moment, I don't know how to identify the problem.  (Btw, I've tried to execute it as administrator with the same result.)

    Thanks in advance for any guidance.

    Best,
    David

    PS: I've uninstalled and reinstalled 4.1 several times, always with the same result.

     
  • Patrick Mary

    Patrick Mary - 2012-11-12

    Because I previously had the same problem with a corrupted Tulip setup file (during the download, I suppose),
    I first suggest you to check that your Tulip installation directory contains the same subdirectories and files that the
    one of your colleage. If not check the Tulip setup file.
    If everything seems ok, in order to expect having some error message displayed, you may try to run the main Tulip exe
    in a command prompt (previously launched in administrator mode)
    The main Tulip executable is the tulip.exe program found if the bin subdirectory of the installation directory of Tulip.

    Hope this helps.
    PM

     
  • David Monarchi

    David Monarchi - 2012-11-12

    Thanks, Patrick.  I can't access my friend's machine, and he's out of town.  I did run tulip.exe from a command prompt in administrator mode as you suggested, but no messages were displayed.  One thing I've noticed by watching the list of processes executing is that tulip starts and then immediately terminates.  Does this tell you anything?

    Thanks again.

    Best,
    David

     
  • Antoine Lambert

    Antoine Lambert - 2012-11-12

    Hi,

    I think I know what's wrong. I had the same issue recently.
    The problem comes from a lock file created by Tulip
    that is still present on your hard drive.
    Look in the folder :
    C:\Users\<your_login>\AppData\Local\Tulip 4.2
    If there is a file named tulip.lck, delete it and
    you should then be able to execute tulip.exe.
    If that path does not exist on your hard drive,
    search for the tulip.lck file with the file explorer.

    That bug has been fixed since the 4.1 release.

    Antoine
    That bug

     
  • David Monarchi

    David Monarchi - 2012-11-12

    Thanks for the information, Antoine.  I don't have the path you listed, so  I searched all of my drives for that file (tulip.lck).  (Just to be sure, I searched for any file with an lck extension.)  It's not on my machine.  Could it be named something else?

    Also, the path you listed implies that 4.2 has been released, but I can't find any place to download it.  Is it not generally available yet?

    Thanks again.

    Best,
    David

     
  • Patrick Mary

    Patrick Mary - 2012-11-13

    David,

    I suggest you to monitor the system calls of tulip.exe
    There is a simple advanced tool to do this:
    'Process Monitor' available at
    http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx
    Don't forget to filter your monitoring using the 'Filter option' and to only display the entries
    matching 'Process Name' is tulip.exe

    Hope this helps.
    Patrick

     
  • David Monarchi

    David Monarchi - 2012-11-13

    Thanks, Patrick!  You and Antoine solved the problem.  Process Monitor is a great tool, and it enabled me to see that the failure was indeed caused by the lck file, as Antoine had said.  I'm mildly confused as to why the search process in Windows Explorer didn't find the file when I searched for it days ago since I began the search in a parent of the directory in which it was located.  MS at its finest, I guess.  :-) 

    Please communicate my apology to Antoine for (somehow) missing the file.  And thanks again to both of you for your patience and assistance.  With any luck this thread will help others who encounter the same problem.

    Best,
    David

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks