Wrong Python version detected (mac OS 10.6.8)

Help
Laure
2013-01-04
2013-04-20
  • Laure

    Laure - 2013-01-04

    Hello,

    I had already Python 2.7.3 (v2.7.3:70274d53c1dd, Apr  9 2012, 20:52:43) installed -and working- on my mac before installing Tulip 4.1.
    When launching Tulip, I get the message "Python version mismatch. Please install python 2.7 for bindings to work properly. Detected version is 2.6".
    What can I do?
    Thanks

     
  • pika78

    pika78 - 2013-02-19

    Hello

    I share  the same issue and I would like to know if there is a way to declare the path of the existing versio of python 2.7 somewhere in a Tulip conf file.
    Many thanks for your help

     
  • Antoine Lambert

    Antoine Lambert - 2013-02-19

    Hi,

    This bug has been fixed in the upcoming Tulip 4.2 in which a lot
    of efforts have been done in order to improve the Python bindings and
    their integration into the new Tulip GUI.

    Until then to bypass the bug in Tulip 4.1, you can do the following:

    1) Open the following file in a text editor : /Applications/Tulip.app/Contents/MacOS/tulip_launcher

    2) add the following line before the last line of the sh script:

    export PATH=/Library/Frameworks/Python.framework/Versions/2.7/bin:$PATH

    3) save the file and start Tulip from the dock : the Python issue should be solved

    Cheers,

    Antoine

     
  • pika78

    pika78 - 2013-02-19

    Many thanks Antoine for this very quick answer.
    Indeed I have done as you suggested, but to no avail. This does not start Tulip.
    I pasted the line just after the command changing directory and before the very last line.
    But Tulip doesn t start.
    I am a little confused
    Many thanks for any hint
    Philippe

     
  • Antoine Lambert

    Antoine Lambert - 2013-02-19

    Here is the content of my tulip_launcher file

    #!/bin/sh

    wd="${0%/*}"
    cd $wd/tulip/bin
    export PATH=/Library/Frameworks/Python.framework/Versions/2.7/bin/:$PATH
    DYLD_LIBRARY_PATH=$wd/tulip/lib DYLD_FRAMEWORK_PATH=$wd/../Frameworks ./tulip


    But the fact that Tulip won't start could come from another bug I know (fixed in 4.2)
    Check the content of your Mac temp directory. You can get its path through the following command:
    python -c "import tempfile;print tempfile.gettempdir()"
    If there is a file named tulip.lck, delete it and then Tulip should start

    Hope that it will help

    Antoine

     
  • pika78

    pika78 - 2013-02-19

    Yep ! it worked…
    I have the same tulip_launcher file as you have and
    I did exactly hat you suggested and Tulip started without requesting version 2.7 of python, indicating that it found it.

    MAny thanks for your quick response.
    This great !
    Philippe

     

Log in to post a comment.