Recent Tulip (version > 4) in Ubuntu?

  • Alain L'Hostis

    Alain L'Hostis - 2014-05-13

    I am able to run the Tulip 3.7 in Ubuntu 13.10, fine. this can be found on standard repository of Ubuntu.
    But is there a way to run newer versions, like the current 4.5? I am not skilled enough to compile it myself, so it would be great to have a repository with recent version of the Tulip.

  • Adam Miller

    Adam Miller - 2014-05-13

    I'll try and look into building a package for you. Otherwise, you'll have to use my script to build and install it, which may or may not require some interaction.

  • Alain L'Hostis

    Alain L'Hostis - 2014-05-16

    Dear Adam,
    thanks a lot for the help. Please be aware that I have never before done a compile in linux!
    1 regarding the script
    I have downloaded the sources of Tulip
    have copied the "" in the tulip directory
    and have run "sh"
    this is the error message I got: Syntax error: word unexpected (expecting ")")

    2 regarding the binaries, I have dowloaded them but am unable to install it: i expected some .deb files but can't find them so I'm lost

  • Alain L'Hostis

    Alain L'Hostis - 2014-05-20

    Dear Adam,
    reading more carefully you nevertheless short message, I succeeded in running the binaries on my Ubuntu machine. the problem is now that this 4.4 version crashes when I open my tlp file which could be opened and edited on the 3.7 version of Tulip running in Ubuntu 13.10.
    So I'm still in need for help!

  • Adam Miller

    Adam Miller - 2014-05-20

    Well, likely the expected format of the file changed between those versions. I would suggest you repeat your work with the tulip binaries I gave you, and use the new tlp file. I doubt it will crash after that.

    Sorry for the late reply, I've been in San Francisco for the past 3 days.

    Anyway, as far as the .deb vs the files I gave; I think if you unzip, there should be a bin directory where the tulip binaries are. Just run those.

  • Alain L'Hostis

    Alain L'Hostis - 2014-05-21

    I don't think this hypothesis is the right one: tulip crashes the same way when I generate a random graph through the interface.

    Last edit: Alain L'Hostis 2014-05-21
  • Adam Miller

    Adam Miller - 2014-05-21

    Darn... ok well I'll get a more up to date linux tulip version built for you, and then hopefully that bug will have been fixed downstream. Otherwise, we can file a bug report. I don't really use the graph saving capability.

    An alternative is for you to be more active about finding out the precise reason why it crashed; the compilation setting is debug, so it has source lines compiled into it to help you. Might want to wait though until I can get a more up to date version out... it'll be just a bit.

  • Alain L'Hostis

    Alain L'Hostis - 2014-05-22

    thanks a lot for your help.
    I feel that my knowledge of Unix is really not sufficient.
    In the previous packages you sent me I was easily able to run the binary file, it was on a different machine, but this time at my office, I find it impossible.
    1. when I typed "tulip" in the terminal while located in the install/bin directory of the downloaded package it launched the 3.7 version of tulip installed through the regular Ubuntu software installer
    2. I removed the 3.7 version using Ubuntu software installer; then I got a message saying "no file of this type"
    3. searching on the internet how to run a binary I found this command "./tulip" and then I got an error message saying "error while loading shared libraries:"
    4. great I thought, let's install this library; I tried by installing it from Synaptic, a different more recent version though, the 2.23.52
    5. the error message I receive is exactly the same as before, so I'm blocked!

    by the way I successfully ran yesterday the edge bundling algorithm on a 4.5 version installed on windows 8.1, which is my ultimate goal, but I feel frustrated not to be able to run it in Ubuntu

    Last edit: Alain L'Hostis 2014-05-22
  • Adam Miller

    Adam Miller - 2014-05-22

    Yeah, sounds like there's some package that that particular .so needs; the error report on DL open is shit because if a library needs another recursively, it doesn't print the entire dependency chain, just thr file that couldn't find all its dependencies. Anyway, you can use the Linux ldd command to manually search for all libraries. So, youd find the library its trying to load and do ldd <that library="">.

    More than likely though, you probably would be fine just dropping a sym link to the new file in /usr/lib

  • Alain L'Hostis

    Alain L'Hostis - 2014-05-22

    effectively ldd says => not found

    and effectively the file is not present in my system, I only have the more recent one I installed with Synaptic

    trying to understand what symbolic links are, not obvious to me, and trying to stupidly create one, not successful so far...

  • Alain L'Hostis

    Alain L'Hostis - 2014-05-23

    Dear Adam,
    I got some decisive help from a colleague down here.
    He managed to compile or recompile the Debian packages that he found of the version 4.5 of tulip for my Ubuntu 13.10.
    This time it worked for me without crashes on the files that caused my problems before.
    So thanks again for the time spent on my case. I just wanted to let you know that I was able to go on.
    I do not know though what is the problem with the binaries you produced. My colleague told me that there was several choices during compilation or context elements of your own Linux system that could explain the problems I encountered on my own machine.
    All the best, now edge bundling algorithm runs and this is great!

  • Adam Miller

    Adam Miller - 2014-05-23

    Could you ask your colleague to tell how he reproduced the Debian packages
    ? I would like to be able to do that with tulip for future users.

  • Alain L'Hostis

    Alain L'Hostis - 2014-05-25

    it's a bit "olé-olé" operation that he did, I mean tricky.
    As far as I understood he added the debian "sid" repository in the Ubuntu packages list
    then downloaded the Tulip deb packages and recompiled it, took some dozen of minutes to realise.
    by the way it confirms that the 4.4 is not functioning and only the 4.5 is.
    I will ask him the exact procedure for your own sake, and for mine because I have Ubuntu 14.04 on my laptop and would like to have Tulip working on it.

  • Alain L'Hostis

    Alain L'Hostis - 2014-05-28

    ouf, I've done it!
    so step by step this is what I've done, based on a french howto

    1. Edit the list of sources
      $ sudo gedit sources.list
      add the line for the Debian "sid" version where all the new programs are installed, because I have seen that the Debian package of Tulip exists in the "sid" version of Debian:

    deb-src sid main contrib non-free

    2 then in the terminal:
    $ apt-get update
    to update the list of packages

    3 Create a folder named Tulip-4.5-Debian
    dowload there the sources and the deb as it seems by the command:
    $ apt-get source tulip

    4 update the dependances tree:
    sudo apt-get build-dep tulip

    5 indicate the details of the future packet, like the author, the distribution of linux and email of the package creator:
    (there i needed to install "dch")
    $ sudo apt-get install devscripts

    move to the root of the sources folder :
    $ cd Tulip-4.5
    $ dch --local alhostis

    6 and finally the great moment:
    $ debuild -us -uc

    7 ok then the deb packages are created one step backward in the folders tree, and I manually installed all the packages by double cliking on each of them and reading error messages from the software installer of Ubuntu (this step is boring but I didn't find the right way)

    at that stage I could run tulip 4.5 from the unity menu, GREAT!

    and I do not know how to make all this useful for other persons, I wish I could but I'm a bit lost in the process...

  • Adam Miller

    Adam Miller - 2014-05-29

    Don't sweat helping others, I will try to augment my build scripts to generate debian file installers on linux.


Log in to post a comment.