$ gcc --version
gcc (GCC) 4.6.0 20110415 (prerelease)

I ended up commenting out contrib target from Makefile because after commenting out parcomb, the next  contrib library gave the same error.



On Sat, May 7, 2011 at 9:49 AM, Hongwei Xi <hwxi@cs.bu.edu> wrote:
On Sat, 7 May 2011, sam lee wrote:

>>Hey, when I `make all`, I get this error:
>>
>>....
>>cp bootstrap1/atsopt_gc
>>"/home/slee/Downloads/ats-lang-anairiats-0.2.4"/bin/atsopt
>>cd contrib/parcomb; make all
>>make[1]: Entering directory
>>`/home/slee/Downloads/ats-lang-anairiats-0.2.4/contrib/parcomb'
>>"/home/slee/Downloads/ats-lang-anairiats-0.2.4"/bin/atscc -Wall -O2 -c -o
>>dynloadall_dats.o dynloadall.dats
>>/home/slee/Downloads/ats-lang-anairiats-0.2.4/bin/atsopt --output
>>dynloadall_dats.c --dynamic dynloadall.dats
>>[compile_file_to_file] is sigtermed
>>make[1]: *** [dynloadall_dats.o] Error 1
>>make[1]: Leaving directory
>>`/home/slee/Downloads/ats-lang-anairiats-0.2.4/contrib/parcomb'
>>make: *** [contrib] Error 2
>>
>>Is parcomb library out of date?

I was told the same by another user. What is the version of gcc you used?

--Hongwei

Computer Science Department
Boston University
111 Cummington Street
Boston, MA 02215

Email: hwxi@cs.bu.edu
Url: http://www.cs.bu.edu/~hwxi
Tel: +1 617 358 2511 (office)
Fax: +1 617 353 6457 (department)