#15 Requires Ruby 1.9 or above and complains about Ruby 2.0

2.0
closed
bug (5)
2013-03-14
2013-03-14
Anonymous
No

Here is my command:

ruby Atlas-SNP2.rb -i Sample401.final.bam -r ucsc.hg19.fasta -o Sample401.atlas.vcf -n Sample401 --Illumina

Here is my error:
Require ruby 1.9.X or above, your ruby version is 2.0.0

Is this a bug?

Discussion

  • Danny Challis

    Danny Challis - 2013-03-14
    • labels: --> bug
    • status: open --> accepted
    • assigned_to: Danny Challis
     
  • Danny Challis

    Danny Challis - 2013-03-14

    Hello, thank you for bringing this to our attention. Yes it is a bug in our version checking code. We will fix this issue in the trunk version and it will be included in the next release. As a temporary work-around you can disable the check by removing lines 112-115 in Atlas-SNP2.rb and lines 508-516 in Atlas-Indel2.rb. Please let us know if you have any other problems.
    Thanks,

    Danny.

     
  • Danny Challis

    Danny Challis - 2013-03-14

    The fix to this bug has been committed to the code trunk and tested with Ruby version 2.0 with no problems. It will be included in the next release. Thanks again for bringing this to our attention.

    Danny.

     
  • Danny Challis

    Danny Challis - 2013-03-14
    • status: accepted --> closed
     


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks