#69 none of the projectiles fire properly in 1.5a


I downloaded the source tarball for version 1.5a
and compiled them on Fedora Core 5

Here are my environment, allegro, and gcc versions:

Linux minidex.cool.com 2.6.16-1.2111_FC5 #1 Thu May 4
21:16:58 EDT 2006 i686 i686 i386 GNU/Linux


After getting around the compile time error I described
in bug [ 1492359 ], the make succeeded and I played a
few games. All the menus worked fine, but during game
play, none of the weapons seem to work correctly. Small
missiles will take V shaped flight paths with no arc
what so ever, and roller weopons never detonate. they
just zig zag around the screen forever, and the surface
has no effect. It just continues zig zagging through
the ground.

I downloaded the tarball for version 1.1 as well, which
also had the abs/fabs problem from bug [ 1492359 ], but
after fixing that and doing the make, the projectiles
all work as expected during game play.

When time permits I will see if I can determine what
changes in the new version cause the weird weapon
behavior, but for now, at least the problem is noted in
this bug report.


  • Jesse Smith

    Jesse Smith - 2006-12-20
    • status: open --> closed-fixed
  • Jesse Smith

    Jesse Smith - 2006-12-20

    Logged In: YES
    Originator: NO

    This problem will not exist in 2.0 as we're using the 1.1 code base. The problem which was
    introduced in 1.5a will not be included.


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks