Unable to insall plugin

Help
2006-10-21
2013-04-18
  • Scott Maroney

    Scott Maroney - 2006-10-21

    I am a new user of Eclipse and I failed to install the astyle plugin successfully.  I tried the full install and the update method install.  Both failed to find the net.sourceforge. ... AstylePreferences class.

    Any ideas to what I'm doing wrong?

    Thanks,
    Scott

     
    • Larry

      Larry - 2006-10-22

      Let me know your eclipse/jdk and OS version.

      Probably you use eclipse 3.1 and use update site to install, which is not supported.

      For quick answer, you can send email to me directly

       
    • Scott Maroney

      Scott Maroney - 2006-10-25

      Oops, I forgot the details:
        o Eclipse v3.2.1
        o Win32

      The other posting lists Java version, but I'm not sure how to determine this. 

      What else do you need?

       
    • Larry

      Larry - 2006-10-25

      * JDK version 1.4.? or 1.5.?
      * which way do you install it, update site or download plugin directly
      * which astyleclipse version

      And also please cleanup the directory (delete old astyleclipse and run eclipse -clean)

       
    • Scott Maroney

      Scott Maroney - 2006-10-26

      How do I determine what JDK I'm using?  All Java related plugins seem to be 3.2.1 (Same as Eclipse)

      I installed it through the update site. 

      I deleted all of the astyle related plugin stuff in my plugin directory, ran an eclipse -clean, and tried a new install using the update manager.  For some reason, the update manager only worked if I looked for updates for already installed components.  I guess I don't know how to fully uninstall the plugin.

      So, after all of this, I "updated" to the new version 1.0.101, and ran into the same problem.

      The exact error is the following:
      Unable to create the selected preference page.

      Reason:
      Plug-in net.sourceforge.astyleclipse was unable to load class net.sourceforge.astyleclipse.preferences.AstylePreferencePage.

      And then when I click on details, I see:
      net.sourceforge.astyleclipse.preferences.AstylePreferencePage

       
    • Larry

      Larry - 2006-10-26

      * Check JDK version

      Start Eclipse, and click
      "Help->About Eclipse SDK->Configuration Details"
      In the listed information, you shall find one line like
      "java.version=1.5.0_08"
      1.5.0_08 is the JDK version.

      If it is 1.4.x like, upgrade to 1.5 is safe though it shall work with latest 1.4.x

      * Check astyleclipse version in eclipse

      When you installed, please check
      "Help->About Eclipse SDK->Plugin Details"
      find the row of astyleclipse, and see the real version
      It is to avoid installation failure

      I will have travel during weekend, check after that. 

       
    • Scott Maroney

      Scott Maroney - 2006-10-26

      I see this:
      java.runtime.version=1.4.2_07-b05

      How do I upgrade that?

       
    • Scott Maroney

      Scott Maroney - 2006-10-26

      I upgraded to JRT 1.5.x and voila!  It works.  Now I understand that other post.  Thanks for all of the help.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks