Preference-page not accessible

Help
knopfpiano
2006-10-23
2013-04-18
  • knopfpiano

    knopfpiano - 2006-10-23

    Hi, after copying the plugin to eclipse-dir I tried to access the astyle-preferences in Window->->Preference.
    I get an error-msg:
    "Unable to create the selected preference page. Reason: Plu-in net.sourceforge.astyleclipse was unable to load class net.sourceforge.astyleclipse.preferences.AstylePreferencePage."

    I use
    eclipse-V3.2.1,
    AStyle-plugin: astyleclipse-1.0.101.v200610192129.zip

    Tried it with previous eclipse-V3.2 and
    astyleclipse-1.0.5.v20061001.zip

    Both don's work.

    Any idea?

     
    • knopfpiano

      knopfpiano - 2006-10-23

      My Java-version is
      "1.4.2_06".
      Regards and thanks

       
    • knopfpiano

      knopfpiano - 2006-10-23

      current java is
      "1.5.0_06"
      now it works fine

       
    • Larry

      Larry - 2006-10-24

      But with the astyleclipse-1.0.101.v200610192129.zip, it shall work with 1.4.x version under eclipse 3.2, can you give me your OS version ?

      My testing platform is W2K+Jdk1.4.2_12b03.

      Probably you forget to clean the old astyleclipse , try to remove all old astyleclipse and run eclipse -clean.

      rgs/larry

       
      • knopfpiano

        knopfpiano - 2006-10-27

        Hi,
        it's either w2k or xp,
        your jdk is versions higher. This might be the problem.
        I don't have it anymore 'cause using 1.5 now.
        Regards

         
    • monkius

      monkius - 2006-11-06

      I am running into this problem as well.  Whenever I try and bring up the Astyle preference page I get the "unable to load class net.sourceforge.astyleclipse.preferences.AstylePreferencePage" error message.

      I am running Fedora Core Linux 6 which has:
      - Eclipse version 3.20
      - java -version:
      java version "1.4.2-beta"
      Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2-beta-b19)
      Java HotSpot(TM) Client VM (build 1.4.2-beta-b19, mixed mode)

      I setup eclipse to use 'Software Update' to get the astyle eclipse plugin, which appears to have downloaded: Astyleclipse Feature 1.0.101.v200610192129

      Do I need to have installed astyle separately before I can use the plugin?

       
    • Larry

      Larry - 2006-11-08

      Sorry, you have to use java 1.5 version, I struggle for a while, but still cannot make it work for jdk 1.4 now.

      If you really need jdk1.4, i can put extra effort on it.

      /larry

       
    • Cetateanu Marius

      Well i have jre1.5.0_06 and Eclipse 3.2.1 on win xp with sp2.
      And i'm having the same problem.
      What is frustrating is that i can see the prefernce page if i create my own astyle plugin project and i debug it.

       
    • Larry

      Larry - 2006-11-26

      I have no Win XP env. nearby, help me to fix it if you can access the svn /larry

       

Log in to post a comment.