#1 I can't get it to work...

open
nobody
None
5
2003-10-20
2003-10-20
Anonymous
No

I've got ASFrecorderX installed on my computer running Mac OS
X v 10.2.3. I've got Windows Media Player X installed. I've tried
to use ASFrecorderX to download several different asf (mms://)
files, but it never works. With one of the files I get the following
message in the log:

>>>
Resolving host: 'a1857.v00289.c28.g.vm.akamaistream.net'
connecting to: a1857.vmg3.akastream.net
sending request [356 bytes]
waiting for reply...
unknown content-type: application/vnd.ms.wms-hdr.asfv1
reply: 200 - OK
>>>

With the other files I try nothing happens at all for ages! I paste
in the address, hit 'Start', the button changes to 'Stop' and
nothing happens. If I then click in the log area, the button
changes back to 'Start' again but the program hasn't done
anything. If I leave it for a minute or so, it comes up with a
"connect() failed: 60" error, which I assume is a timeout, but I
tried streaming the file with IE and it worked fine! What's going
on?

Any help would be greatly appreciated!
Thx

<paltin14@hotmail.com>

Discussion

  • Nobody/Anonymous

    Logged In: NO

    I just ran across this very thing as well. Running the
    command-line ASFRecorder I saw this error in the log:

    unknown content-type: application/vnd.ms.wms-hdr.asfv1
    reply: 200 - OK

    HTTP-Reply:
    HTTP/1.1 200 OK
    Content-Type: application/vnd.ms.wms-hdr.asfv1

    If you have The Proxomitron (http://www.proxomitron.info)
    you can use this header filter to change the content-type
    header to one that ASFRecorder recognizes (just make sure to
    set Proxomitron as your proxy in ASFRecorder):

    [HTTP headers]
    In = TRUE
    Out = FALSE
    Key = "Content-Type: Fix ASF files for ASFRecorder (in)
    [rcl]"
    Match = "(application/vnd.ms.wms-hdr.
    asfv1|application/x-mms-framed|video/x-ms-asf)"
    Replace = "application/octet-stream"

    Or you can modify the code and recompile it to recognize
    those content types.

     
  • Rogue_Spider

    Rogue_Spider - 2004-03-13

    Logged In: YES
    user_id=246319

    I ment to answer sooner on this one -oops-
    akamaistream.net there's an egg of a hex
    old ibeam server they actualy exploited the
    glith in asfrecorder that would be the 200 ok error
    I have had little to no succsees writing out/
    the only option that ive come up with is write out
    error control and return value but havna had enough
    time to do it;(

     
  • Christian Sonne

    Christian Sonne - 2005-04-08

    Logged In: YES
    user_id=409471

    The one file you mention that yields the error:
    unknown content-type: application/vnd.ms.wms-hdr.asfv1

    I had the same problem just today,, and after a bit of
    digging, I managed to write a patch that (seems) to fix the
    problem - the reason I say 'seems' is that file wasn't
    really playable in any player I had at hand...

    I then look through the mailing-list, and previosuly
    submitted patches, and lo and behold, a patch allmost 100%
    identical to mine had been submitted back in may of 2004,
    this DOES make the program download data, but I'm getting
    weird timecode errors that may or may not have anything to
    do with the patch - give a try and see for yourself...

    http://sourceforge.net/tracker/index.php?func=detail&aid=956813&group_id=21852&atid=374533

     
  • Peter Backes

    Peter Backes - 2005-12-17

    Logged In: YES
    user_id=845643

    apply the corona patch.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks