Trouble deploying to artifactory

Help
Sarah
2009-06-05
2013-04-05
  • Sarah

    Sarah - 2009-06-05

    I've been trying to set up artifactory to allow group members to deploy to the "snapshots" repository and admins to the "releases" repository.  I am able to do it with the "releases" repository no problem. Attempting to deploy as a non-admin user to "snapshots" hasn't worked.  What I have done is create a group with delete, deploy and read access to the snapshots repository.  Then I created a user and added that user to this group.

    After setting up the user in my settings.xml file and adding the <snapshotRepository> tag to my pom I tried to deploy.  I get a 403 permissions error.  If I then go (as an admin) and make that user an admin that user can deploy to the snapshots repository just fine.  I assume I've just missed a step in setting this up.  I haven't found answers on this issue elsewhere so it's probably really simple :)

    Thoughts?

     
    • Sarah

      Sarah - 2009-06-05

      Forgot to mention that I'm using version 2.0.5

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks