Welcome to Help

Help
Mark Vitek
2009-11-29
2013-04-24
  • Mark Vitek

    Mark Vitek - 2009-11-29

    Welcome to Help

     
  • Andrew West

    Andrew West - 2010-02-01

    Ok, I've got a simple problem that's probably got a simple solution staring me in the face: I have Arpage loaded and hooked up, settings set to mimic this guy's, and the Jack Timer rolling via Qjackctl- but I don't get any MIDI output from Arpage.   Arpage allows MIDI to pass thru it when the Jack Timer is stopped, but acts like a black hole when the Timer is rolling.  Any ideas?  I compiled from source on Gentoo Amd64, for the record.

    Thanks,
    Andrew

     
  • Anonymous - 2010-04-20

    I have the exact same problem. I downloaded and compiled arpage 0.2 tonight. I connect my keyboard to Rosegarden, Rosegarden to the ALSA MIDI through port, the JACK MIDI through to Arpage, and Arpage to Yoshimi. I can play Yoshimi through Arpage up until I start the Jack transport rolling, then silence. No MIDI seems to reach Yoshimi from Arpage until I stop the Jack transport, whereupon I can start playing again. I compiled from source on Ubuntu Studio 10.04 64-bit.

     
  • Mark Vitek

    Mark Vitek - 2010-04-20

    Hi Richard,
    When the JACK Transport is not rolling, arpage passes MIDI on any channel.  When the transport is rolling, it will only pass MIDI on the channel specified in the spin button of the UI.   Make sure the channel on which you are transmitting is the same channel shown in arapge.  Please let me know if this works or not. Thank you.

     
  • Anonymous - 2010-04-21

    straypacket,

    Thanks for your reply. I have checked the settings and I think they are OK, but I'm still having the same problem. Rosegarden is sending out on channel 1 to the MIDI through port, and the MIDI through port under alsa_pcm is sending to Arpage input 1. Arpeggiator 1 is set to channel 1 and the "Channelized" box is checked. Yoshimi is listening on channel 1. Rosegarden is configured to use Jack transport. Still, I can play on the Yoshimi synth until I start Jack transport rolling, then all midi messages from my keyboard stop arriving at the synth until I stop Jack again.

    I tried fiddling with the MMC and MTC settings in Rosegarden, setting Rosegarden to Master for both and connecting Rosegarden's sync out to the MIDI through port, but this didn't help.

    Do you think I am missing something fundamental?

     
  • Anonymous - 2010-04-21

    For a test I took Rosegarden out of the equation and set Ardour to function as Jack time master. My M-Audio Axiom keyboard transmits on channel 1 straight to the ALSA MIDI Through port. Jack MIDI Through is connected to Arpage input 1. Arpage output 1 is connected to Yoshimi. Yoshimi listens on channel 1. Arpage's first arpeggiator is set to Channelized, with channel 1 selected. Again, I can play the synthesizer until I start Jack rolling, but as soon as Jack starts rolling there is silence.

     
  • Anonymous - 2010-04-26

    I did a little bit of poking around in the code. The problem seems to lie with the following line in the process_callback method of jack_process.cc:

    if ( pos.valid & JackPositionBBT ) {

    As far as I can see on my system, when Jack is running pos.valid is always seems to evaluate to false. So when Jack is running no midi input gets processed.

     
  • Mark Vitek

    Mark Vitek - 2010-04-26

    Hi Richard - In my tests, Ardour does not seem to provide enough Bar/Beat/Tick data for Arpage to function.   I have not tried Rosegarden - but QTractor and Seq24 seem to provide solid BBT data, which will ensure that the conditional check you refer to evaluates true.

     
  • Anonymous - 2010-04-27

    Thanks for your reply. I don't actually think it's Ardour's fault; I think I had something configured wrongly.

    After reading your message I tried Arpage with SEQ24 and got it working. Then I started up Rosegarden too, then Ardour. It still worked. Then I switched the time master from SEQ24 to Ardour and it still worked, so I closed SEQ24 and it still worked. When I turned off the time master setting in Ardour (so there was now no time master) Arpage went silent again.

    I'd guess that I hadn't actually got Ardour functioning as time master before, though for some reason I thought I had. So, anyway, I got it working thanks to your explaining that it needed a source of bar/beat/tick data. I enjoyed playing around with it and when inspiration next strikes I'm pretty sure there'll be some arpeggios in there.

     

Log in to post a comment.