#288 Wanderer crashes if specified font can't be found

general
open-postponed
5
2010-10-30
2010-10-24
Pavel Fedin
No

If Wanderer can't find icon font (missing font is specified in prefs) iconlist.mcc will crash in OM_NEW. This happens when it gets font pointer by querying MUIA_Font init-time attribute and gets NULL pointer. Then it tries to refer to this pointer without a check.
Perhaps it should pick up its font from renderinfo supplied by Zune.

Discussion

  • Krzysztof Smiechowicz

    The problem is elsewhere - Wanderer just shows it:

    Wanderer calls IconList with NULL font, because diskfont.library is not able to open "arial.font". This happens on the other hand because diskfont.library is not finding the arial.font in FONTS:, because ExAll call returns 0 (== done) on it's first call. This means not all fonts are returned, because the passed 1024 bytes buffer is too small to get them all in one go.

    Note: revision 34917 is free off this bug.

     
  • Krzysztof Smiechowicz

    • labels: 390823 --> 390819
     
  • Krzysztof Smiechowicz

    Fixed in revision 34975

     
  • Krzysztof Smiechowicz

    • assigned_to: nobody --> sonic_amiga
    • status: open --> closed
     
  • Krzysztof Smiechowicz

    • status: closed --> closed-fixed
     
  • Pavel Fedin

    Pavel Fedin - 2010-10-30
    • labels: 390819 --> Utilities/Applications/Demos
    • status: closed-fixed --> pending-postponed
     
  • Pavel Fedin

    Pavel Fedin - 2010-10-30

    I know that this problem is gone. But i would not say it is fixed.
    Fixed is another problem in new version of emul.handler. Wanderer's bug was just triggered by this problem.
    It can be triggered again if the user ocassionally (or intentionally) deletes a font which is selected in Wanderer and reboots. I hope you agree that such actions should not render the system unbootable. Wanderer could just pick up default font then, even if it's Topaz/8.

     
  • Pavel Fedin

    Pavel Fedin - 2010-10-30
    • status: pending-postponed --> open-postponed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks