#90 Screen initialisation fails first time

v0.2.6
open
1
2003-08-10
2003-07-16
Manuel Moos
No

1) The doesn't-remember-resolution bug I mentioned a few days ago
is still
at hand, probably it has something to do with the way a resolution in
GL
is set:

Couldn't set video mode: Couldn't find matching GLX visual
(this message repeated 4 times)

When I change the resolution from 640x480x32 to 800x600x32 it
works fine,
but after a restart it flips back to 640x480x32. All other configuration
options are remembered, and the directory armagetron/var exists.

Also I'd like to report that your game runs fine on RedHat 9, Linux
kernel-2.6.0-test1
and a hacked NVidia driver ;-)

Discussion

  • Manuel Moos

    Manuel Moos - 2003-07-20
    • milestone: 316047 --> 316048
     
  • Jelle Raaijmakers

    Logged In: YES
    user_id=739763

    I'd like to add that the hacked drivers didn't had anything
    to do with this bug; I encountered the same problem using
    kernel-2.4.20 and the official NVidia drivers from
    www.nvidia.com.

     
  • Manuel Moos

    Manuel Moos - 2003-08-10
    • milestone: 316048 --> v0.2.6
     
  • Döme Zoltán

    Döme Zoltán - 2003-11-10

    Logged In: YES
    user_id=772081

    it is present with debian sarge (with 2.4.22 kernel and official
    nvidia drivers) too.
    strange but when i set the resolution to 1024x768x16 and not
    1024x768x32 then it remembers it and works fine.

    plus at first it had segfaults (as normal user and as root too),
    then it was somehow cured by an unknown force...

     
  • Manuel Moos

    Manuel Moos - 2005-08-29

    Logged In: YES
    user_id=34808

    Armagetron Advanced 0.2.8_beta1 now polls the list of
    available resolutions; perhaps this gives better behavior in this
    case?

     

Log in to post a comment.