#5771 Giantrat noise while entering int_sedah_storage and house5

None
open
nobody
None
5
2014-03-16
2014-01-28
Czimmy
No

While entering int_sedah_storage, you hear the sound of a giant rat, but there is no inside

Discussion

  • bluelads4

    bluelads4 - 2014-02-02

    Hello, the problem appears on every door in Sedah on the Fado mines map around the storage and I unfortunately think that it also happens with other doors maybe. I tried to find the issue but couldn't run through all code parts earlier. Maybe someone knows if it might be a problem related to changes around entities over all or door entities?

    Greetings

    Bluelads4

     
    Last edit: bluelads4 2014-02-02
  • bluelads4

    bluelads4 - 2014-02-02
    • summary: Noise while entering int_sedah_storage --> Giantrat noise while entering int_sedah_storage and house5
    • Group: -->
     
  • bluelads4

    bluelads4 - 2014-02-02

    Oh and there isn't any rat on the map

     
  • Kimmo Rundelin

    Kimmo Rundelin - 2014-02-04

    There probably was a giant rat at the top left corner of the cave zone. Then as the user is removed the coordinates default to (0, 0), so the rat can be heard. The player's position should probably default to somewhere clearly outside the map for sound.

     
  • bluelads4

    bluelads4 - 2014-02-11

    Kiheru is right, there is/now was a giantrat in the upper map corner which made those noises. I moved the rat away from the map entrance now for avoiding sounds of it showing up in the buildings, it's a fix for now. Not sure how the position can be changed, that's why I just use the moving away thingy now as a workaround, hope that is ok :)

    Greetings

    Bluelads4

     
  • bluelads4

    bluelads4 - 2014-02-11
    • status: open --> closed-fixed
    • assigned_to: bluelads4
     
  • bluelads4

    bluelads4 - 2014-02-11
    • status: closed-fixed --> pending
     
  • bluelads4

    bluelads4 - 2014-02-11
    • status: pending --> open
     
  • bluelads4

    bluelads4 - 2014-03-16
    • assigned_to: bluelads4 --> nobody
     
  • Kimmo Rundelin

    Kimmo Rundelin - 2014-03-16

    When investigating the issue, I found the cause is that the player is added on the new zone near the coordinates where a sound was started at a previous zone.

    The bug is rather non trivial to fix. The client needs either a way to stop sounds caused by a certain entity (related to bug 5704), or a way to stop a certain class of sounds (stop all sounds that should be stopped immediately at zone change).

     


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks