aprsd won't transmit from HF to aprs.net?

  • Rolf Winterscheidt


    this is my second try to start with aprsd.
    Short overview:
    - Installed aprsd 2.1.4 precompiled for SuSE-Linux 8.1
    - Got the password-String for my call (dg8kbr)
    - Connected to third.aprs.net
    - Got data from third.aprs.net, could connect to some local  ports via telnet and watch incoming Data
    - Seen that my call (dg8kbr) is registered in third.aprs.net and Password is ok. Seen some data going down and up (counter increases).
    - Driven around my house and sent my positions (as dg8kbr-9).
    - Were very sad not to see the results on findu.com

    So everything looks like it is working fine expect of not sending the dg8kbr-9 (maybe it won't send a position at all).

    How can I get some logdata (except aprsd.log which only showed me if I'm connected or not).
    Maybe data _is_ sent but I'm not aware of this.

    Please tell me to RTFM if I should do but I did'nt find something for my problem.

    best regards,
    Rolf Winterscheidt

    • Rolf Winterscheidt

      The beacon is sent, I can see dg8kbr in findu.com. But my mobile station dg8kbr-9 isn't updated.

      BTW: I get the data via EAR-out to a TNC, so I cannot send to HF (I don't need this way).

    • Rolf Winterscheidt

      I figured out that even the Perl-udp-Example works. My Gateway transmits this testpacket to the internet. So only RF to Internet won't work, but I could imagine that other stations than mine will be forwarded perfectly.

      Is it impossible to give the Gate the call DG8KBR and the mobile the call DG8KBR-9 ?

    • Rolf Winterscheidt

      tcpdump -X host grep third.aprs.net|grep -i dg8kbr.9
      shows me some packets going out to aprs.net just when they come in at the RF side. So propably aprsd works fine but third.aprs.net won't let the packet in. Someone can help?


    • Chuck Byam

      Chuck Byam - 2003-05-12

      try another server: first/second or something local.  BTW, 2.1.4 is old code and you should really look into a newer version.

      -- Chuck

    • Rolf Winterscheidt

      I tried about 10 servers, local or far away. Nothing works. Also I tried 2.2.5-7 and even this doesn't work. So is it possible that I need a officia digi-call than just mine? I'm dg8kbr and tried to digipeat my car (dg8kbr-9). I set the correct password, so it really should work, but it doesn't. Why does the perl-example works but the gate from hf to internet doesn't?

      I tried hard for so many months, please help me...


    • Rolf Winterscheidt

      I gave up, it seems that RF->Inet won't work with aprsd...


    • Chuck Byam

      Chuck Byam - 2003-11-04


      Sorry to hear that you are having so much trouble getting this to work.  Here are a couple of suggestions that may help:

      -- use version 2.2.5-15, there was a bug fixed in this version that had to do with the serial rf/inet interface.

      -- run the server in standalone mode (./aprsd from the console) and see if the console output provides any clues.

      -- connect to your server (telnet localhost <port>) on port 14580 (rawtncport) and/or 14579 (localport) and see if aprsd is receiving (valid) data from your tnc.

      -- telnet <hub server your connected to> [port] | grep 'yourcall' this will only display data matching 'yourcall'


    • Rolf Winterscheidt


      thank you for reply. I receive data and can monitor everything. Even the sample script aprsd_udp_example works fine. But automatically digipeat the received stations to e.g. second.aprs.net isn't working, even when I am displayed there as a registered user with password. Tcpdump perhaps _sends_ these positions but the receivers won't display them e.g. by telnetting to it or just looking into findu.com (I tried much more than only some of *.aprs.net).
      Second thing: Obviously it is not easily done to set up a repeater only for RF to RF, just repeating. Is this correct?

      Rolf (ok, one more try :-) )


Log in to post a comment.