own repository; list and upgrade do not work

  • hgrube

    hgrube - 2011-04-15

    I am trying to build up my own packet server for our product 'nscale'
    using appupdater (Appupdater Version: 1.4.2 - Rev: 902).

    I started with a new repository (discribed in nscaleapps.xml) and
    two of our applications with 2 different versions each (described in nscaleversions.xml).

    I am able to install and remove for example the older versions of each software component.
    It works fine (silent and no silent).

    Appupdater is also able to show the (-full) available program packages.

    But unfortunatly appupdater is not able to show the list of installed packages and their versions.
    (And as result?) It is also not able to upgrade the installed packages to the newer versions.

    I reduced in the appupdater.ini file the search directories to
    search_dirs = C:\Programme\Ceyoniq\nscale Administrator, C:\Programme\Ceyoniq\nscale Server
    where the to nscale applications are still installed.

    What can I do to make it work?

    My appupdater.ini file:

    y = 0
    width = 800
    x = 0
    height = 500

    search_dirs = C:\Programme\Ceyoniq\nscale Administrator, C:\Programme\Ceyoniq\nscale Server
    metalink = ${PROGRAMFILES}\Aria2\aria2c.exe
    http_proxy =
    sig_check = SKIP
    https_proxy =
    unknown_txt = C:\Dokumente und Einstellungen\All Users\Anwendungsdaten\Appupdater\unknown.txt
    temp_dir = C:\Dokumente und Einstellungen\All Users\Anwendungsdaten\Appupdater\temp
    apps_xml = ftp://packages.nscale-inside.de/AppUpdaterTest/nscaleapps.xml
    ignore_regex = ${WINDIR}\ServicePackFiles, ${WINDIR}\\$NtUninstall
    status = security, stable, beta
    unzip = C:\Programme\Appupdater\unzip.exe
    auto_download = True
    reporting = True
    ftp_proxy =
    cache_dir = C:\Dokumente und Einstellungen\All Users\Anwendungsdaten\Appupdater
    auto_install = True
    refresh_expire = 604800
    metalink_params = -M %i -d %cache -allow-overwrite=true
    update_expire = 86400
    unzip_params = %i -d "%tempdir"
    keyring = C:\Dokumente und Einstellungen\All Users\Anwendungsdaten\Appupdater\appupdater.gpg
    ignore =
    auto_key = True
    gnupg =
    package_lists =
    cmd_prefix = start /B /WAIT /BELOWNORMAL ""
    installed_txt = C:\Dokumente und Einstellungen\All Users\Anwendungsdaten\Appupdater\installed.txt
    index_hour = 2

  • nabber00

    nabber00 - 2011-04-15

    Can you please include your nscaleapps.xml content?  Also look at your installed.txt and see if your applications appear in there.  Odds are the hashes aren't matching up.

  • hgrube

    hgrube - 2011-04-19

    Yes, you are right. The hashes did not match. And we are also using software wrappers which will not be changed by every update of our software. So it seemed to me like a moving (but not changing) target.
    Now it works fine! Thank you very much for the hint.

    May I ask you a further question? Is it possible to upgrade a single package or a package group instead of upgrading the whole bunch of installed packages?


  • nabber00

    nabber00 - 2011-04-19

    There is an option to "ignore" updates to certain packages if that helps.

  • hgrube

    hgrube - 2011-04-27

    1. Option "ignore": How do I have to use it? As parameter for the "-upgrade" command. Or do I have to use the "ignore =" parameter in the appupdater.ini file? It is not exact the function which I am searching for. If (e.g.) package groups like "Administrator Tools", "Server Components" and "Client Components" were defined it would be useful/comfortable to force an upgrade only to a single package group or to all package groups excluding a single package group…

    2. By the way. Is there  any description of the appupdater.ini file and its parameters available?

    3. To detect which application (version) is installed I need that a ".eclipseproduct" (two of our applications are Java/Eclipse based) is been analyzed by Appupdater. Unfortunately it ignores that kind of files. May be the reason is the leading point in the filename. What can I do to make this work?


Log in to post a comment.