repairing permissions

moonra
2007-02-07
2012-10-09
  • moonra

    moonra - 2007-02-07

    Hello, I'm runnign applejjack on my new mac laptop for thhe first time. It's been stuck in "repairing permissions" mode for the last 15 hours.

    Suggestions?

    thanks,

     
    • Kristofer Widholm

      For now, hit CTRL+C (control key and c key at the same time) to break out of AppleJack and then type 'reboot' and hit return to restart your computer. That will get you safely out of AppleJack.

      Can you send me details of your machine? What model, what processor, what version of Mac OS X, etc. Also, can you attach or include the AppleJack log file (it is located at /var/log/AppleJack.log.

      Can you tell me if the little white dots are still moving across the screen, or if that never happened?

       
      • moonra

        moonra - 2007-02-07

        that's for the quick reply. all I can tell you for now is:

        Yes - the little dots are moving across the screen, and in front of each row it says: "repairing permissions"

        everything else I will post later, when I get home.

         
        • moonra

          moonra - 2007-02-13

          is that it? I was hoping for some additional tips.

           
          • Kristofer Widholm

            In Finder go the the "Go" menu (english), and then select "Go to folder..." (or you can just hit cmd+option+G)

            In the ensuing dialog, type /var/log and hit return. Finder will open the /var/log folder for you. You'll find the log in there.

             
      • moonra

        moonra - 2007-02-08

        ok.

        model: iBook G4
        processor: 1.42 GHz PowerPC G4
        Mac OS X version 10.4.8

        finally, how do you find the log, I can't seem to locate it?

        thanks

         
    • Kristofer Widholm

      Sorry, I've been out of the country on business and Internet connectivity has been sketchy. I'm puzzled by the permisssions repair failing on your machine as it is a pretty well tested piece of hardware for AppleJack.
      If you could send me the AppleJack log (check the ReadME in /Library/Documentation/AppleJack), I might be able to form some idea of why, but without the computer in front of me, I can't quite parse out why this is happening.

       
      • moonra

        moonra - 2007-02-25

        hi again,
        i found 2 separate library folders on my computer, both have a folder called documentation, neither have a file called applejack (?)

         
        • Kristofer Widholm

          You should find it at /Library/Documentation/AppleJack --IF you installed version 1.4.3. If you have an earlier version, the documentation is not installed for you.

          If you installed version 1.4.3, and you don't have the documentation, then something went wrong during the install process. Try installing again.

           
    • Ilgaz

      Ilgaz - 2007-03-14

      Repair permissions issue never ending was an issue with timing on powerpc macs and as far as I know, it was fixed on latest version (both final and earlier betas).

      Are you sure you have installed latest version? It is easy to make sure, just grab the latest version and reinstall it. Multiple reinstalls won't harm this type of program especially because it uses Apple Installer package.

       
    • John C. Tull

      John C. Tull - 2007-03-14

      I ran 1.4.3 last evening after my 10.4.9 update. Using 'applejack auto' everything froze with a kernel panic during repair permissions. I am on a MacBook C2D 15" 2.16 ghz with 2 GB Ram. Below is the entire log output. You can see that it stops prematurely. The console output indicates a kernel panic, and I have to hold the power button to force a reboot. I tried 3 times. I have reinstalled applejack, but have not retried running. I do not know why a reinstall would help, so I have not gotten around to going through this again.

      AppleJack 1.4.3, Copyright 2002-6 Kristofer Widholm, The Apotek * Tue Mar 13 19:14:42 PDT 2007. Gathering information... Running in automatic mode, with automatic restart - User ID: 0, NAME: root - OS Version: 10.4.9 - Virtual memory directory appears to be /private/var/vm. - Local root filesystem is journaled AppleJack will repair disks in 10 seconds. Disk repair Success! Either your disk had no errors, or it was repaired successfully. Done with disk repairs -- AppleJack will repair permissions in 10 seconds. Permissions repair Let's mount the startup file system for write access...
      Done.

      Checking for /tmp directory:
      /tmp directory exists.
      Done.
      Configuring minimal Tiger services...

       
      • Kristofer Widholm

        Please see this thread: https://sourceforge.net/tracker/index.php?func=detail&aid=1680298&group_id=79562&atid=557035

        After updating your OS, the OS sometimes needs to boot up normally at least once (mine did it twice automatically) before you do anything else.

        Seriously, why are people running AppleJack after an update anyway and before you've booted up even once? Have you identified a serious issue that requires AppleJack?

        I would perhaps run AppleJack before an upgrade/install, but certainly not right after, unless my machine was fubar.

        AppleJack is a troubleshooting/preparedness tool, not a maintenance tool.

         
        • John C. Tull

          John C. Tull - 2007-03-14

          Perhaps there should be documentation for us folks who are unable to reason the purpose of this tool. Why would repairing your disk, repairing permissions, validating the system's preference files, and getting rid of possibly corrupted cache files not be a maintenance routine? I occasionally would used 'fsck -fy' in single-user mode prior to finding applejack to see if everything appeared well with my hard drive, with or without symptoms of problems. Likewise, it seems like a good idea to do these things on a semi-regular schedule to me. Hence, an OS update is a good cue to run some maintenance routines.

          If this is a known issue after OS updates, there should be some mention in the readme file.

           
    • Hone Melgren

      Hone Melgren - 2007-03-16

      I think Kristofer needs to clarify what Applejack is for

      It is a trouble shooting tool not a maintence tool . He think he means he has designed it as a tool for when things go wrong not as tool you run religously on a Sunday afternoon after coming back from Church.

      From the readme file "AppleJack is a shell script intended to assist you in trouble-shooting startup problems in Mac OS X"

      And yes you are right there John there should be a paragraph in the read me file set out quite clearer for someone to see "do not run this immediately after a system update"

      I would suggest the readme file be rewritten like this :

      Title

      <brief intro>
      <contents>

      <main readme stuff>

      That way people can see straight out just be looking at the table of contents about runnning it after a system update

      ie dont

      Lastly the 10.4.9 update did update some kernel extensions and device drivers. These will not have been completely updated until after the first reboot afterwards

       
      • Hone Melgren

        Hone Melgren - 2007-03-16

        Woops can't edit the crazy message

        "He think he means that he designed..." should read
        "I think he means that he designed..."

        And Kris If you want me to rewrite your readme for you I will

         
        • Kristofer Widholm

          Mr. Melgren,

          Yes, I would be very happy if you did help me write the ReadMe. I can send you the latest version. Please send me an e-mail via the SourceForge messaging system, and I'll send the latest version as an attachment.

          Thanks again.

           

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks