Problem rendering high resolution flames

Help
2007-11-29
2013-04-25
  • protagonyst

    protagonyst - 2007-11-29

    I want to make a render for a high resolution print-out and the rendered keeps crashing. I looked around for an answer but can't find anything.

    I'm using Apophysis v2.02.
    I'm using the 'Export Flame' option to render the flame to disk using the external command line renderer.

    I'm using the following settings:
    Width: 3190
    Height: 2465
    Quality: 10000
    Filter Radius: 0.4
    Oversample: 4

    Batches: 1
    Strips: 4
    Buffer Depth: 64 bits

    Any try to render at a higher resolution or increasing the oversample setting result in the rendered crashing with a 'malloc' error.

    Tried with both the included HQI Renderer and the latest FLAM-3 v2.7.6 with similar results.

    My system specs are the following:

    Intel Core 2 Duo 6400 2.13GHz
    2GB RAM
    Windows XP MCE 2002 w/SP2

    I know I'm pushing the software, but I'd like to know if there's something I'm doing wrong. Is there a way of rendering very high resolution high quality flames without making the renderer crash?

    Best regards,

    Protagonyst

     
    • Jukka Korhonen

      Jukka Korhonen - 2008-04-15

      I know this is more than a late reply but since no one's answered to this I'll give it a shot. :D

      Your settings are quite massive - 4x oversample on that resolution can really choke up things. For example, when I do print stuff on Apophysis (currently using the 3D Hack, which is just excellent), I render with 2.2 gamma (gives nice output when rendering to sRGB), Quality 25-200 (25 works very nice on Inkjet prints, Laser sometimes needs 200 - depends on if you do CMYK separation yourself), Oversample 1, Filter Radius 0 - 1.0 (doesn't really matter on oversample 1, at least on the 3D hack version).

      Those settings render fast and nicely on the internal renderer, and the quality is sufficient for printing. For offset printing I would use quality = 200 - 500.

      Here's what rendered stuff look like on those settings (Q=25; on calibrated monitors the low quality is invisible, since the gammaslope hides everything - this is also true on inkjet printing due to dot gain).

      http://loadus.deviantart.com/art/Sleeping-82530823

      - j

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks