#10 Unable to use IMAP over SSL with JavaMail 1.4

closed-fixed
None
5
2006-05-04
2006-05-04
No

It seems that ImapCrawler cannot use IMAP over SSL when
I switch from JavaMail 1.3.3_01 to JavaMail 1.4. It
complains about "Unconnected sockets not supported".

Discussion

  • Christiaan Fluit

    Logged In: YES
    user_id=617090

    The solution is to add the following method to all
    SSLSocketFactory implementations:

    public Socket createSocket() throws IOException {
    return factory.createSocket();
    }

    See also this JavaMail forum topic:
    http://forum.java.sun.com/thread.jspa?threadID=731248&tstart=0

     
  • Christiaan Fluit

    • status: open --> closed-fixed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks