Hi Oliver,

Sorry for the inconvenience ...  Reading/writing in gz format is still developmental in APBS, we didn't test them over all platform/compiler combination. As for Linux, I tested your examples on a 32-bit CentOS box with the latest Intel compilers (icc/ifort 12.0.0), and it worked just fine, I got the same results as on Mac OS X.

Thanks,

Yong


On Mon, Dec 13, 2010 at 9:15 AM, Oliver Beckstein <oliver.beckstein@bioch.ox.ac.uk> wrote:
Hi Yong,

A while back you fixed the issue of reading dx.gz files in svn1623.

I reported this as fixed:

On 22 Nov, 2010, at 18:50, Oliver Beckstein wrote:

> svn1623 is working as it is supposed to – my test case (with your fixes...) gives exactly the same total energy.


However, that was a bit premature.

* When I compile with gcc/gfortran on Mac OS X/Darwin then it seems to be working; the attached test case gives the same total energy, regardless of using gzipped or plain dx files.

* When I compile on Linux Ubuntu 8.04/9.04/10.04 on either i686 (32 bit) or x86_64 (64 bit) I will either get different answers (with the plain dx total energy being the same as on Darwin---on x86_64) or even fail to solve (on i686) as shown here:

Parsing input file solv_dxgz.in...
Parsed input file.
Got paths for 1 molecules
Reading PQR-format atom data from 1OED.pqr.
% BUILDBAND: dpbfa problem:  1
% BUILDBAND: leading principle minor not PD...
% BUILDOPS: changing your MGSOLV
% BUILDOPS: to iterative...
% MVCS: rhs is zero on finest level
% MVCS: iters on coarse grid:  100
% MVCS: iters on coarse grid:  100
...

(This was compiled on Ubuntu 9.04 with GNU compilers 4.3.3 and

       ./configure --prefix=$HOME/Library/
       make
       make install

)

Note that the failure is ONLY observed when trying to read dx.gz files.

* I tried both gcc 4.3/4.4 and icc/ifort 9.1 or 10.1 on Linux.

* I used gcc-mp-4.4 (release 4.4.5) and gfortran-mp-4.4 from MacPorts on Mac OS X 10.6.4 or gcc/gfortran 4.4.1 on Mac OS X 10.5.8.


In order to run the tests:

       tar -jxvf TESTING.tar.bz2
       cd TESTING
       export APBS=/path/to/apbs  # if apbs is not on PATH
       ./RUN_all.sh
       ./DIFF_out.sh

If everything works then you should not see a difference in 'Global net ELEC energy'. See examples below:

Example of a successful run (on Darwin):

@@ -132,5 +132,5 @@
 PRINT STATEMENTS

-print energy 1 (ref0) end
+print energy 1 (ref1) end
  Local net energy (PE 0) = 7.465005631049E+02 kJ/mol
  Global net ELEC energy = 7.465005631049E+02 kJ/mol



Example of failure (GNU 4.4 on x86_64):

 PRINT STATEMENTS

-print energy 1 (ref0) end
-  Local net energy (PE 0) = 7.465005631049E+02 kJ/mol
-  Global net ELEC energy = 7.465005631049E+02 kJ/mol
+print energy 1 (ref1) end
+  Local net energy (PE 0) = 1.587888288299E+03 kJ/mol
+  Global net ELEC energy = 1.587888288299E+03 kJ/mol


Sorry for the long email but I hope that this will give you enough information to get an idea of what's going on. Please let me know if you need more information.

Cheers,
Oliver




--
Oliver Beckstein
SBCB Unit, University of Oxford
email: oliver.beckstein@bioch.ox.ac.uk
web: http://sbcb.bioch.ox.ac.uk/oliver/


------------------------------------------------------------------------------
Lotusphere 2011
Register now for Lotusphere 2011 and learn how
to connect the dots, take your collaborative environment
to the next level, and enter the era of Social Business.
http://p.sf.net/sfu/lotusphere-d2d
_______________________________________________
apbs-users mailing list
apbs-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/apbs-users