Art of Illusion 2.9.1

2012-02-19
2013-06-05
  • Peter Eastman

    Peter Eastman - 2012-02-19

    Version 2.9.1 is now released.

    Sorry vidiot for still not having resolved your installation problem.  But since I've now had multiple Windows 7 users say it works for them, I think the problem may be something more specific to your computer, and I don't want to make other people keep waiting for it.

    Peter

     
  • Harald G

    Harald G - 2012-02-20

    I understand.
    Since AoI is running even after those "broken" installations I'm with you.

    So: Thumbs up for the new features in AoI 2.9.1!

    Harald

     
  • Tami

    Tami - 2012-02-22

    I downloaded Aol and tried to install it - I was following instructions step by step, and it seemed to be going just fine - until I came to step 7.  There was no instructions, nothing what to do next - just blank.  I pressed "Next" to go to step 8, and then waited-and waited.  Nothing happened.

    I have Window 7 64 bits, and I do have Java installed.  Just wondering what is up with the step 7 coming up blank.  Thanks.

     
  • Bill French

    Bill French - 2012-02-22

    - hobbyist4
    Install to any folder EXCEPT programfiles x86. Make your own directory in the root folder and install there.

    - Peter
    Never had any install problems with any version of AOI.
    Running Win7 - 64 bit, and 32 bit, - just make sure to install anywhere but windows recommended default location !

    ---> Bill

     
  • Harald G

    Harald G - 2012-02-22

    Peter,

    I de-installed Java 64 and the installation runs fine even in step 7 (where I could see the question "For all users..? for the first time since 2.8.1).
    After Step 8 WIN asked me if the program was installed properly, - but at least a big step ahead.
    So if I would like to use Java 32 and 64 bit parallel I have to accept this (maybe).

    Harald

     
  • Tami

    Tami - 2012-02-23

    I installed it elsewhere as suggested.  The step 7 still came up blank, but somehow AOI  2.9.1  is now installed and running fine, at least as far as I can see.  *scratches head*

     
  • OniOid

    OniOid - 2012-02-27

    Thank you, Peter.
    I just got my first 64 bit laptop, and it will be my 10th anniversary using AoI is this year…
    Wow, 10 years…  64 bit is enough for everyone. ;)
    Shades of the past seeing Nate and Julian posting recently, incidentally. (Hey guys.)

     
  • delia

    delia - 2012-02-28

    Wow, this is so cool, to be able to render textured images straight into quicktime. Works wonderfully on a mac. Sooo pleased. Regards Matthew

     
  • Luke S

    Luke S - 2012-02-28

    Just some status updates on what worked and what didn't.

    1. Install was very smooth - no issues at all on win Vista (lzPack installer)
    1b. installing in the suggested location (in a user folder instead of the main program files folder) Means that SP Manager works smoothly for the first time in my using it. :)

    2. JOGL I know that something was said on the beta thread about 'finally got it fixed' Sorry, still breaks my display any time a window is re-sized. Not really a big deal for me, but something that is still out there.
    2b. If I launch with the built in launcher .exe file, aoi will sometimes crash, but the error log says that the problem is in native code - not just aoi, but the whole JVM crashed - its a little sporadic, but seems not to happen when I launch with a batch file (linux guys would call it a shell script) I only mention it because in all the cases I have a file for, part of the sun jogl code was listed as the part that caused the issue. - So, Maybe I've got a really messed up installation somewhere, or maybe the JOGL library is buggy - I really don't know.

    Overall, It works, and I will enjoy using it.

    ljsails

     
  • Peter Eastman

    Peter Eastman - 2012-02-28

    Do you have your video driver up to date?  That's the first thing I look for when someone is having problems with JOGL.

    Peter

     
  • Luke S

    Luke S - 2012-02-28

    Yes it is. (according to microsoft - take that with about a pound of salt)
    So is my JVM (just updated yesterday)

    I'm starting to agree with someone over on friendlyskies: "Penguins are so cute. One of these days I'm going to open up my window and let one in."

    Two things - is it normal for the 'portable' zip to not be able to use JOGL? I was downloading that when checking out the beta to save on download time.

        And: could older versions of AOI be interfering? I have back to 2.8.1 - because a couple of plugins haven't been updated yet.

    ljsails

     
  • Bill French

    Bill French - 2012-02-28

    Luke -

    I have every version since 2.8.1 installed at same time - no problem here -

    I typically switch between them for various reasons, and the only connection between them seems to be that preferences are shared to all versions. Sometimes good - sometimes bad, but they all work.

    ------? Bill

     
  • ma0mpt

    ma0mpt - 2012-02-29

    JOGL

    @ljsails

    Hi,

    This happens to me too. It also happened with 2.8.1 and with 2.9.

    I'm using an ASUS EeePC 1015PEM, Windows 7 32 bit, and just installed the v latest Intel  GMA 3150 drivers.

    Brand new install of AoI 2.9.1, and I specified the java library path to 'lib' in my startup script.  I know it is seeing the JOGL dlls because I don't get any errors in the command window.

    Puzzling and mildy annoying, but it doesn't stop me using AoI because I just turn JOGL off.

    Mark

     
  • Luke S

    Luke S - 2012-02-29

    @Mark: About right.

    I think this is probably NOT an AOI issue. Might want to file a bug report with sun - there is a web address in the hserr_pidXXXX.log file that the JVM dumps in the directory you launched from.

    I also wonder if this is an older version of JOGL - the date on the files is back in 2008 ??

    Still, I can turn JOGL off, so it works for the time being.

    ljsails

     
  • delia

    delia - 2012-03-01

    Hello All
    I have downloaded and installed 2.91 on a Mac 10.6.8 and found that the lathe tool doesn't work with the plugin ViewLayout , it just switches the view from 3+1  to 1 window. Lathe tool works fine with the standard view system.
    Regards Matthew
    ps not sure if this is the right place to note this …

     
  • Harald G

    Harald G - 2012-03-18

    We found out that AoI hangs on rendering compared to version 2.8.1 or compared to the advanced raytracer.
    Since the files are to large to put them in the bug tracker, it is maybe possible for others to test them out?

    The files are attached to that post from kbe:
    http://www.aoi-board.de/index.php?action=posts&fid=29&tid=1196&site=1#b_10705

    We have test it under Win 7 and Linux and the behavior is nearly the same:
    We can't tell at which frame exactly AoI will hang but it will.
    The problem doesn't occur with AoI 2.8.1 or with the advanced raytracer in 2.9.1.

    Hope this information might help find the reason for that issue.

    Greetings
    Harald

     
  • Luke S

    Luke S - 2012-03-19

    Hey, I remember that thread. Thought seeing what all the fuss was about might be interesting (and educational) Followed your link - clicked on one of the test files - got (a lot of german - says verbotten) I think the forum will not let you download unless you have an account. I don't speak (or read) german so - even getting an account might be a challenge. Any chance these could be made available elsewhere?

    Just wondering ljsails

     
  • Bill French

    Bill French - 2012-03-19

    Vidiot -

    I have been posting about the hanging problem with 2.9.1 since it came out - no one acknowledges this fact - except for you finally. The way I get around it is by using 2.9.1 for design and texturing, then use 2.8.1 for rendering.

    I notice the hangups especially on complicated scenes (many objects ) AND/OR use many rays ( as in water or glass scenes).

    btw - I am running Win7, 64 bit, 4GB ram, dual core.

    ----> Bill

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks