It looks like aoe-72 isn't quite building against 2.6.31... I'm getting the following error:

CC [M]  /root/aoe6-72/linux/drivers/block/aoe/aoeblk.o
/root/aoe6-72/linux/drivers/block/aoe/aoeblk.c: In function 'aoeblk_request':
/root/aoe6-72/linux/drivers/block/aoe/aoeblk.c:255: error: implicit declaration of function 'elv_next_request'
/root/aoe6-72/linux/drivers/block/aoe/aoeblk.c:255: warning: assignment makes pointer from integer without a cast
/root/aoe6-72/linux/drivers/block/aoe/aoeblk.c:256: error: implicit declaration of function 'blkdev_dequeue_request'


Any chance a patch for this is around the corner?

Thanks,
Brian