Hi.
 
I did a install of Vblade on a Slackware 13 on a Dell PowerVaultNF500.
this machine has 3 hardware raid being sda 160 GB, sdb and sdc 1TB each..
 
At the Solaris 9 machine i downloaded and installed the CORDaoe-1.4-sparc packge.
 
For the initial tests porpoise I started Vblade on linux exporting the hole sdc disk and on solaris side i did:
 
- create a file /etc/aoe.conf with the following content:
    aoechan 0 ether bge0
 
- started the aoe:
    # /etc/init.d/aoe start
    # aoectl list
    0/1/1
    # aoelabinit /dev/rdsk/cads101s0
 
The disk was labeled and i could format and create a filesystem on it. Tests done i moved on, did a shitdown
on aoe process on Solaris, wiped out the sdc disk.
 
I created a new partition on the sda diask that is used as follow:
 
    /dev/sda1    /
    /dev/sda2    /swap
    /dev/sda3    /usr
    /dev/sda5    /var
    /dev/sda6     /   ->  replica  of /dev/sda1  and second boot partition
 
At this new partition i installed EVMS and configured bonding so as to have a 3G ethernet interface bonding 3 ethernet cards. So now i got 2 / system  one plain and another with the modifications done.
 
after few days, I created a lvmgroup with sdb and sdc, created a lvm volume /dev/lvmdsk/disk1 and exported it with Vblade and once again on solaris i did:
 
    # /etc/init.d/aoe start
    # aoectl list
    0/1/1
    # aoelabinit /dev/rdsk/cads101s0
    aoelabinit: /dev/rdsk/cad101s0: may have old label, use -f to force
    # aoelabinit -f /dev/rdsk/cad101s0
    # format
    Searching for disks...done
 

    AVAILABLE DISK SELECTIONS:
       0. c1t0d0 <SUN72G cyl 14087 alt 2 hd 24 sec 424>
          /pci@1c,600000/scsi@2/sd@0,0
       1. c1t1d0 <SUN72G cyl 14087 alt 2 hd 24 sec 424>
          /pci@1c,600000/scsi@2/sd@1,0
       2. cad101s0 <drive type unknown>                                   <<<<<<<<<<< It wasnt labelled !!!!
          /pseudo/aoed@101
 
The new disk wasnt labeled, second the fromat command.
 
I though it was a lvm issue and destroied the lvm and exported tge sdc with Vblade. The result was the same, then i tryed to export the sdb with the same results. I even created a sda7 partition  to test with the same results, the solaris machine cant label the disc.
 
I rebooted the machine using the plain installation system that had alread worked and made the tests all over again with the same results.
 
I also removed the CORDaoe package and reinstaled it on the solaris machine with the same result, the aoelabinit complais and the format command do not see the volume as.a labeled device.
 
by the way if i do a fdisk -l on another linus machine on the same network it shows the disk has a Solaris label on it:
Disk /dev/etherd/e1.1 (Sun disk label): 64 heads, 890 sectors, 68 cylinders
Units = cylinders of 56960 * 512 bytes
 
           Device Flag    Start       End    Blocks   Id  System
/dev/etherd/e1.1p1             0        68   1936640    2  SunOS root
/dev/etherd/e1.1p3             0        68   1936640    5  Whole disk
 
This is what i get on the log of the solaris machine:
Dec 15 13:26:37 dbv240 genunix: [ID 936769 kern.info] aoed114 is /pseudo/aoed@114
Dec 15 13:26:37 dbv240 aoed: [ID 801845 kern.info] aoed101 0/1/1: no disk label
Dec 15 13:28:34 dbv240 aoed: [ID 801845 kern.info] aoed101 0/1/1: no disk label
Dec 15 14:38:46 dbv240 aoemon[4537]: [ID 702911 daemon.notice] enabled 0/1/1 firmware 4.20 maxbuf 16 maxdata 1024
Dec 15 14:39:48 dbv240 aoed: [ID 801845 kern.info] aoed101 0/1/1: no disk label
Dec 15 14:48:55 dbv240 aoemon[4638]: [ID 702911 daemon.notice] enabled 0/1/1 firmware 4.20 maxbuf 16 maxdata 1024
Dec 15 14:49:14 dbv240 aoed: [ID 801845 kern.info] aoed101 0/1/1: no disk label
Dec 15 14:55:16 dbv240 aoemon[4638]: [ID 702911 daemon.warning] 0/unknown: Ill-formed message:
Dec 15 14:55:16 dbv240 aoemon[4638]: [ID 702911 daemon.warning] dst ff:ff:ff:ff:ff:ff src 00:15:17:c4:34:ba type 0x88a2
Dec 15 14:55:16 dbv240 aoemon[4638]: [ID 702911 daemon.warning] --invalid AoE header: 46 bytes
Dec 15 14:55:16 dbv240 aoemon[4638]: [ID 702911 daemon.warning]         08 00 00 01 01 01 00 00 00 00 00 10 40 14 02 10
Dec 15 14:55:16 dbv240 aoemon[4638]: [ID 702911 daemon.warning]         00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
Dec 15 14:55:16 dbv240 aoemon[4638]: [ID 702911 daemon.warning]         00 00 00 00 00 00 00 00 00 00 00 00 00 00
Dec 15 14:56:01 dbv240 aoemon[4721]: [ID 702911 daemon.notice] enabled 0/1/1 firmware 4.20 maxbuf 16 maxdata 1024
Dec 15 14:56:20 dbv240 aoed: [ID 801845 kern.info] aoed101 0/1/1: no disk label
Dec 15 15:04:02 dbv240 aoed: [ID 801845 kern.info] aoed101 0/1/1: no disk label
 
 
Sorry for the long and boring email, but i wanted to give all the information available.
 
Please, can someone shade some light on this issue?
 
Best Regards,
Carlos Xavier.