ERROR: open RFCOMM port

  • peterfaj

    peterfaj - 2010-04-29

    When I try to run anyRemote in server mode, it says it cannot open the port.
    I ran:

    anyremote -s 19


    Search configuration file /home/peter/.anyremote.cfg
    ERROR: can't open 19
    ERROR: open RFCOMM port
    Connection closed or lost
    INFO: Already closed ?
    Error on closing port

    Bluetooth however works fine as far as I've used it. KBluetooth lists the phone and I can send files to/from the phone.
    I could not pair the devices using KBluetooth though. It said the phone does not support input service. But I was able to pair the devices using the phone.

    My phone is Nokia N95.

  • peterfaj

    peterfaj - 2010-04-29

    I used all-in-one2.cfg

  • Mike

    Mike - 2010-04-29

    Firstly, rfcomm's are NOT used in server mode.
    So, i guess, You need to specify "-s bluetooth:19"

  • peterfaj

    peterfaj - 2010-04-29

    Yes, that helped. I got no errors and anyremote ran. However, when I tried to connect my phone to the channel 19, all of the keys had a lock for their icon. I'm guessing it's a config problem. I will try another config.
    Also, is there a way to start anyremote using kAnyRemote?

  • peterfaj

    peterfaj - 2010-04-29

    I tried another config (vlc) and icons did appear, but they don't do anything. My computer does detect them however, anyremote console says:

    --2010-04-29 14:43:08--  http://localhost:8080/?control=stop
    Resolving localhost...
    Connecting to localhost||:8080... failed: Connection refused.
  • peterfaj

    peterfaj - 2010-04-30

    Never mind, the vlc config was the problem. I've now tested it with the amarok2 config, everything works fine now. Just the configs need a little editing. Thanks for all your help.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks