Problems with $(CfgDir)

Help
2009-01-22
2012-12-10
  • niflostancu

    niflostancu - 2009-01-22

    Hi!
    I have a strange problem with $(CfgDir) in scripts.

    I run the script from "/home/niflostancu/.anyRemote/cfg-data/Server-mode/script.cfg" (any script, modified to print CfgDir), but $(CfgDir) is "/home/niflostancu/.anyRemote/cfg-data/Server-mode/..", not "/home/niflostancu/.anyRemote/cfg-data/Server-mode" as it should be (notice the extra "/.." at the end)
    I also tested the original all-in-one2.cfg script and it doesn't work because of this bug.
    I'm using ganyremote, but I see it runs anyremote with "anyremote -fe 5050 -f /home/niflostancu/.anyRemote/cfg-data/Server-mode/all-in-one2.cfg -s socket:4321"

    I'm running Ubuntu 8.10 and anyremote 4.15. The bug started when upgrading to anyremote 4.14 from anyremote_4.13 (worked fine in this version). Downgrading solves this bug, but I thought I should report it.
    I looked into the 4.13~1ubuntu7 to 4.14~1ubuntu1~ppa1~hardy1 diff and found that the setCfgDir function (src/parse.c) has been modified between 4.13 and 4.14. I think this is the source of the problem.

    Is this occurring to you, too?

     
    • niflostancu

      niflostancu - 2009-01-22

      Oh, I forgot to mention about my phone, if it has any importance: I have a Nokia E51, connected through WLAN.

       
    • Mike

      Mike - 2009-01-22

      Yes, You definitely right.
      Starting from v4.14 $(CfgDir) points to .../cfg-data/

      I going to update configuration files ASAP.

       
    • Mike

      Mike - 2009-01-28

      Believe this issue is fixed in v4.16

       

Log in to post a comment.