java client bug and connection issues.

  • bifferos

    bifferos - 2011-12-03

    I've downloaded the java client using wap.  I started it up and tried 'connect' it didn't work, then I tried 'auto connect' it didn't work either, just showed 'disconnected' on the screen in both cases, then I tried to set the IP address, just because I got bored, and then it asked me if I wanted to allow the application internet access.  I said 'no', then it gave a javascript error.  I quit the application.  Now when the java application runs it shows the anyRemote progress graphic screen, the progress bar reaches the end and then the application freezes.  Not sure how to get out of this state.  This happens every time I run it now.

    Another question, how do I know whether I've got JSR-82 support?  My phone is really, really cheap, (although bought recently), so it'd be nice to know how I find out.

    About the connection, I can ping the phone, and it's recognised in the device list using gAnyRemote, but I'm a little stuck on Ubuntu with what to do next.  Help says 'cannot find documentation'.

    I got to 'configuration check', under anyremote-J2ME-client it says 'downloaded v4.21', anyRemote is installed.
    Under preferences->server mode I've got upload java client from /home/biff/.anyRemote, I clicked 'Download java client from web', and it puts lots of files in /home/biff/.anyRemote but when I come to click 'upload java' under 'device parameters' it says 'Can not find anyremote-J2ME-client installation.


  • Mike

    Mike - 2011-12-04

    Which phone/model do You have ?
    How did You start anyRemote server on PC ?
    What does 'hciconfig' says on Your PC ?

  • bifferos

    bifferos - 2011-12-11

    Sorry for the long delay replying, my phone is LG C300 Town.  I started (or thought I started) the server on my Ubuntu box using gAnyRemote.  I tried various applications, always the same thing.

    I don't think hciconfig is going to be the problem, as I can transfer files to my mobile.  The communication link seems to be OK, so I think the problem is the phone software.


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks