Stuck on Open/Broken Segment

  • galesl

    galesl - 2009-10-13

    Using Anaphraseus Latest (2009-07-15) and OOo 3.1.1 on Windows XP.

    Things were going well until I tried expanding a segment upward (not sure
    exactly what I did). After that I was stuck in an empty segment. When I tried
    to get out of it I would get error messages like:

    • "open Segment, please close first"
    • "Broken segment, please repair"

    But I can't find any info on closing or repairing a segment. I still had this
    problem even after trying End Translation, closing & reopening the
    document and closing and reopening OOo.

    Can anyone help?

  • Nino

    Nino - 2009-10-13


    one of my friends has a similar problem. He wasn't trying to expand a segment
    he was just translating but when he tried to open the next segment he got the
    message "There is nothing more to translate. Thank you for using
    Anaphraseus!" and he failed to get out of it.

    Can anyone help us too?

    Thanks a lot,


  • Ole Yansen

    Ole Yansen - 2009-10-13

    Hi Nino, hi Galesl.

    Couldn't say something definite.

    Each translation segment after closing should have structure like this:


    If some of service characters ("{0>" etc.) were missing
    Anaphraseus start to complain about broken segment.

    So I suggest to fix "broken" segment in this way, or just delete all
    service characters from segment excepting Source text (translation was
    remembered in TM, so it is not disappeared).

    In your case, Nino, something wrong with source text. Could you email me
    sample of it please ?

    Regards, Oleg.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks