SourceForge has been redesigned. Learn more.
Close

Toolbar icons

2008-11-27
2012-09-14
  • Leonardo La Malfa

    Hi everybody. I have recently come to know about Anaphraseus, and want to say thank you for such a nice project. I am still exploring it, but it seems to work well on Ubuntu 8.10 as an extension of OO 2.4, and I hope to see further developments.

    However, there seems to be a minor glitch with the toolbar icons, which do not appear and are replaced by text (e.g. "Translate (Alt+Down)"). The weird thing is they appear in the menu, but not on the toolbar. Besides, I cannot customise the toolbar, nor choose the visible buttons, for these options are missing, unlike for other toolbars. Before posting, I did search the forum, and found another post ("NeoOffice") where the problem was not solved, eventually. I also followed Oleg's advice to use the standalone version (again with OpenOffice), which came up with two toolbars (surely due to the previous extension still in place). To my surprise, I could customise the new toolbar, but although I chose "Icons Only", the icons never showed up. Please, let me know if a solution is available.

     
    • Ole Yansen

      Ole Yansen - 2008-11-28

      Hi,

      I just searched Web for solution, or at least explanation of the problem.
      Try this links I'v found:
      http://sourceforge.net/tracker/index.php?func=detail&aid=1799478&group_id=198974&atid=967623
      http://answers.launchpad.net/ubuntu/+source/openoffice.org/+question/12243
      http://maketecheasier.com/how-to-make-disappeared-icons-in-openoffice-return/2008/01/02

      Please, let me know if something of this is working.

      Regards, Oleg.

       
    • Leonardo La Malfa

      Hi Oleg,

      Thank you very much for your time, and your answers! Unfortunately, though, none of the above helped. I tried most of the suggestions in the links, but to no avail. Interestingly enough, though, I also tried to install OpenCards, but even before trying the workaround described in the first link (to install a second extension), I could see all the icons of OpenCards toolbar. Anaphraseus, instead, kept showing only text, also after the workaround was complete.

      It is weird, thought, because I can actually see Anaphraseus icons in:
      - Anaphraseus menu;
      - the "Visible Buttons" menu, accessible only from the drop-down menu at the rightmost end of the toolbar available in the standalone version (I forgot to write it in yesterday's post) - which is a customisable toolbar (unlike the one in the extension), and which is actually called Anaphraseus, rather than Add-On 1.
      I am not a computer whiz, but these two points should rule out the explanation given in the 3rd link (which I tried, nonetheless).

      Anyway, this is just a cosmetic glitch, and although I would still like to see all of the icons, I guess I can live without them. In the end, it's a promising application, I appreciate all your efforts, and it's still working although the buttons show an explicative text.

      Many thanks,
      Leonardo

       
    • Leonardo La Malfa

      Great work, Oleg! :)

      Thank you for all your efforts and the time devoted to finding a solution. Anaphraseus toolbar is now populated with icons! After having tried any possible combination of every WF release + every M$ Office version I know of in combination with CrossOver, I think Anaphraseus will remain one of the few working alternatives to WF for me, after having migrated to Linux. WF is a nice buggy tool, but it wasn't built with Linux in mind, for which it finds little or no support.

      I really wish this CAT tool could keep growing stronger and achieve the wide community it deserves, and the impressive performance it seems to promise in a Linux environment.

      Many thanks,
      Leonardo

       
      • Ole Yansen

        Ole Yansen - 2008-12-03

        Hi, Leonardo

        As I suspected, size is matter :-)
        Ubuntu default icon theme is "large icons". It's not compatible with Anaphraseus' small icons.
        To see icons not in standalone version only just select small icon theme (Menu "Tools"-"Options"-"View" "Icon size and style"-"Small").
        It'll do the trick.

        Regards, Oleg

         
        • Leonardo La Malfa

          Hi Oleg,

          You're definitely right: size does matter (as my ex-girlfriend would agree, being an expert in toolbars)! :)
          Anyways, setting a smaller size really did the trick, and now icons are available also when using Anaphraseus as an extension. Sorry for bothering you for such a silly issue, but I'm quite new to OO, and I couldn't figure out the link between the icons and the settings.
          Good work, Oleg, and great support, too. I'm really grateful for your time!

          Many thanks,
          Leonardo

           

Log in to post a comment.