No trusted certificate found

Help
OceanReef
2010-03-18
2013-04-15
  • OceanReef

    OceanReef - 2010-03-18

    I am getting following error in my amtu_error.log file and none of my files gets transferred to Amazon. Not getting any reports from Amazon. Please help
    "A serious error has occurred. Message: The Amazon server has reported an error. The text of this error is: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: No trusted certificate found. Root cause: The Amazon server has reported an error. The text of this error is: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: No trusted certificate found."

     
  • NoBagRqrd

    NoBagRqrd - 2010-03-19

    I am getting the exact same error - checking in the log files shows everything was running normally until 21:10 GMT - then every request has failed with this certificate error.

    I wonder if this is something on Amazon's side?

     
  • OceanReef

    OceanReef - 2010-03-19

    We got update from Amazon, which worked out.
    Please follow the below instructions to correct this problem:

    1) Install java 1.6 on the computer
    2) Go into the /program files/ directory, there will be a java "JRE" directory
    you will need to copy that JRE directory and then go into the Amazon / Merchant Transport directory
    3) replace the JRE folder there with the JRE folder from their ProgramFiles directory

     
  • 430ScudMonster

    430ScudMonster - 2010-03-19

    A couple of other things to mention. You may need to "stop" the amtu service and the monitoring service and then paste the files. Then restart the service and then the monitoring service.

     
  • Anonymous - 2010-03-19

    Hi all,

    Just to let others know….the version of JAVA you download is actually referenced 6 (its 1.6 but they call it 6 on the site).

    Also the Amazon AMTU JRE folder has a subfolder called javaws which is NOT present in the version of java you download and install (JRE6 if it was 6 you got) so dont overwrite the whole folder but only copy over the CONTENTS of the JRE6 folder and overwrite the CONTENTS of the Amazon JRE folder, so preserving the javaws folder.

    If you lose that javaws folder you will have to reinstall AMTU (your settings will still be there).

    Rolf

     
  • NoBagRqrd

    NoBagRqrd - 2010-03-19

    I just spoke with seller support, and they are aware of the problem and expect it to be resolved at their end by this afternoon. 

    As I was on the telephone to them, I came back to this forum and saw the additional posts - I mentioned the suggested solution to the chap on the phone and he had not heard of this yet!

    Do you think someone forgot to renew the SSL certificate?  oops!

     
  • mervick

    mervick - 2010-03-19

    we've got the exact same issue - we tried the steps provided by ocean with no success - including stopping the amtu service, backing up the current version, and starting amtu again with javaws intact and jre at version 6 (1.6).

    is there any news? 

    we also tried calling amazon seller support, they've not heard anything about this issue.

     
  • NoBagRqrd

    NoBagRqrd - 2010-03-19

    I just spoke with Seller Support again (less than 10 mins ago) and they told me they are still fixing the problem,and are aware of this post and the solution in it.  
    The chap I spoke with said upgrading the Java to 1.6 might work or it might not but they hope to have it fixed from their end this afternoon (same as they told me this morning).

     
  • stuart ayre

    stuart ayre - 2010-03-20

    I have updated the java files but now the AMTU service keeps stopping, even if i try starting it it stops. is anyone else having this problem??

     
  • stuart ayre

    stuart ayre - 2010-03-21

    in an attempt to get it to work, I installed the latest version of AMTU and updated the java files and the services is running, all good so far but there is no production folder like im used to! where do the files get downloaded to?

     
  • stuart ayre

    stuart ayre - 2010-03-21

    ah… my bad… it just seem to have created them :)

     
  • 430ScudMonster

    430ScudMonster - 2010-03-22

    And be sure to reboot the machine if AMTU acts funny or doesn't start working.

     
  • organizeit.com

    organizeit.com - 2010-03-22

    This works, but you need the latest version of AMTU, it did not work on the older version we had (No JP option, only US and EU)

     
  • mervick

    mervick - 2010-03-22

    the latest version of AMTU with the latest version (6, or 1.6 JRE) does not work for us.

    We are running this AMTU service on a windows XP box at the moment, firewall(s) disabled, port 443 open and available and we're still getting the same error.

    what versions do work then if not 1.0.9 or 1.0.1 (we've tried both of these versions with the latest JRE)- can someone share these success details with the rest of us?

     
  • Derek Beattie

    Derek Beattie - 2010-03-22

    AMTU has the JRE as part of the distribution, which is build 1.4.2_04-b05, mixed mode.

     
  • fatgeordie

    fatgeordie - 2010-03-22

    crazymervick - I have today successfully re-installed AMTU and Java 6 on an XP box.

    I:
    Stopped AMTU
    Dowloaded AMTU distribution "amtu-win32-vista_win7-support-1.0.9.zip"
    Unzipped the AMTU distribution and copied it over the existing installation
    Installed Java v6
    navigated to c:\program files\Java\JRE6
    Copied the contents of this folder and pasted into the JRE folder in my AMTU installation
    Restarted the PC.

    Bizarrely this did not work first time but after re-copying the Java code it did. Perhaps i missed something first time There should be no need to run the AMTU install script.

    Sorry if this is all obvious but I'm just recording exactly what i did. Hope it may help.. The same procedure also worked on SBS2003

     
  • organizeit.com

    organizeit.com - 2010-03-22

    It’s a pain…

    1) Have Java6 installed
    2) Uninstall the AMTU, it should remove the 2 services, if not remove them.
    3) Reinstall the new AMTU from this site.
    4) Answer all the questions; it should do a ping that will fail.
    5) Make sure the service is not running yet and copy all the JRE files saving JAVAWS folder (as stated above).
    6) Go back and do the configuration again, this time the ping should work and the services created and running.
    7) Make sure you only have 1 ‘configuration account’ and the settings are right, I had a second one that wasn’t helping.

    Sprinkle some reboots in there and that’s what worked for us.  Nothing seemed to work with the old AMTU we had, so that’s what I think did the trick.

     
  • Simon

    Simon - 2010-03-23

    I solved this simply by installing the latest version of java and copying across the jre.

    -Stop the service

    - Find the folder jre6 under your java install (c:\program files\java).

    - Copy the folder to your amtu directory (eg c:\amazon\merchanttransport)

    - Rename the existing jre folder to jreOLD

    -Rename the folder jre6 to jre

    - Start the service.

    No Reinstalling of amtu required, just a quick swap out of the jre. Would have been nice of amazon to warn about this or even be slightly helpful on the phone when i called them, but hey.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks