#14 Win XP Pro installation failure... (solved)

v1.0_(example)
closed-works-for-me
None
5
2003-08-06
2003-08-02
No

WIN XP Pro . with ActivePerl installed at two drives:
one at C: (default installation) and the other comming
with my Apache 2 Server at D: .
I have made the mistake of declaring the Win
Environment variable PERL5LIB with both lib paths
(starting with the server's activeperl). I think (but
am not sure) that this env.variable is the cause of a
lot of trouble with my perl scripts and Amphetadesk v.1.0!
the message at the first startings (both .exe and .pl)
were...
"Perl Command Line Interpreter has detected a problem
and must close."

...and at the log file...
...
Too late to run INIT block at
D:\WAMPP2\PERL\SITE\LIB/Win32/API/Type.pm line 71.
Can't locate Win32/GUI.pm in @INC (@INC contains:
C:\Documents and Settings\Alberto\Mis documentos\My
Website\amphetadesk\lib C:\Documents and
Settings\Alberto\Mis documentos\My
Website\amphetadesk\lib C:\Documents and
Settings\Alberto\Mis documentos\My
Website\amphetadesk\lib %PERL5LIB% D:\WAMPP2\PERL\LIB
D:\WAMPP2\PERL\SITE\LIB C:\PERL\SITE\LIB C:\PERL\LIB
C:/Perl/lib C:/Perl/site/lib .) at C:\Documents and
Settings\Alberto\Mis documentos\My
Website\amphetadesk\lib/AmphetaDesk/OS/Windows.pm line 19.
BEGIN failed--compilation aborted at C:\Documents and
Settings\Alberto\Mis documentos\My
Website\amphetadesk\lib/AmphetaDesk/OS/Windows.pm line 19.
Compilation failed in require at C:\Documents and
Settings\Alberto\Mis documentos\My
Website\amphetadesk\lib/AmphetaDesk.pm line 85.
[20:02:17] Creating a brand new channels file from the
current subscriptions.
Use of uninitialized value in substitution (s///) at
C:\Documents and Settings\Alberto\Mis documentos\My
Website\amphetadesk\lib/XML/Simple.pm line 1016.
Use of uninitialized value in substitution (s///) at
C:\Documents and Settings\Alberto\Mis documentos\My
Website\amphetadesk\lib/XML/Simple.pm line 1017.
Use of uninitialized value in substitution (s///) at
C:\Documents and Settings\Alberto\Mis documentos\My
Website\amphetadesk\lib/XML/Simple.pm line 1018.
Use of uninitialized value in substitution (s///) at
C:\Documents and Settings\Alberto\Mis documentos\My
Website\amphetadesk\lib/XML/Simple.pm line 1019.
Use of uninitialized value in join or string at
C:\Documents and Settings\Alberto\Mis documentos\My
Website\amphetadesk\lib/XML/Simple.pm line 884.
[20:02:18] Creating a brand new settings file from the
current settings.

Discussion

  • Pedro Santelmo

    Pedro Santelmo - 2003-08-02

    this is my log file-hope it helps!

     
    Attachments
  • Morbus Iff

    Morbus Iff - 2003-08-02

    Logged In: YES
    user_id=69804

    Should have nothing to do with your paths (since Ampheta adds its
    own lib/ directory into it, at startup). Since you're using your own
    ActiveState Perl, the AmphetaDesk scripts are expecting to find
    the Win32::GUI module installed somewhere on your box. This
    module isn't installed by default with ActiveState, so you'll need to
    go and grab you own copy. You can get it from http://
    sourceforge.net/projects/perl-win32-gui (you'll have to point PPM
    to the downloaded and extracted package file).

     
  • Morbus Iff

    Morbus Iff - 2003-08-02
    • assigned_to: nobody --> morbus
    • status: open --> closed-invalid
     
  • Pedro Santelmo

    Pedro Santelmo - 2003-08-02

    Logged In: YES
    user_id=453531

    I guess I should first check my ActivePerl configuration. I
    tryied:
    * ppm Win32::GUI
    * deleted mySettings.xml
    * called AmphetaDesk.pl or .exe and crashes perl
    * got the following results... after rearranging lib at
    AmphetaDesk.pl to find ampheta.PM
    3221225477 -- Restarting.
    [Sat Aug 02 04:25:32 2003] [notice] Parent: Created child
    process 2672
    [Sat Aug 02 04:26:05 2003] [notice] Child 2672: Child
    process is running
    [Sat Aug 02 04:26:05 2003] [notice] Child 2672: Acquired the
    start mutex.
    [Sat Aug 02 04:26:05 2003] [notice] Child 2672: Starting 250
    worker threads.

     
  • Morbus Iff

    Morbus Iff - 2003-08-02

    Logged In: YES
    user_id=69804

    It occurs to me that you're trying to use AmphetaDesk as a CGI
    script (based on the fact that you installed it into a "My Website"
    folder and that you snippeted a piece of your Apache error log. If
    that's the case, that's your main problem: AmphetaDesk IS NOT a
    CGI script, and you can't run it as such. It's a client-side
    application only. Regardless:

    * ppm Win32::GUI won't work. You must use the new entry on SF,
    as the version in the PPM repository is old and broken.

    * Modifying the lib path's in AmphetaDesk should not be
    necessary, as they were originally correctly set (as per your first
    paste).

     
  • Pedro Santelmo

    Pedro Santelmo - 2003-08-02

    Logged In: YES
    user_id=453531

    Tryied to download SF 's Win32::GUI but my ppm prefers the
    one that has installed.
    I am afraid there is no way of getting it run.
    Might be I could adapt the *NIX version, if it is not very
    difficult?

     
  • Pedro Santelmo

    Pedro Santelmo - 2003-08-06
    • summary: Win XP Pro installation failure... --> Win XP Pro installation failure... (solved)
    • status: closed-invalid --> closed-works-for-me
     
  • Pedro Santelmo

    Pedro Santelmo - 2003-08-06

    Logged In: YES
    user_id=453531

    Well, the solution was as I expected:
    Re-installed ActivePerl and (mostt important) removed
    PERL5LIB environment variable.
    Not only was your script working wrong but also other
    libraries. I got one XML parser declaring an error: "this
    path has no perl installed" (or something like this). What
    was wrong was declaring an alternative LIB path to the one
    from the main ActivePerl.
    After reinstalling Perl AmphetaDesk started smoothly- GREAT!

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks