tcl/tk init.tcl problem

2003-05-02
2003-05-06
  • Nobody/Anonymous

    I'm having a problem with tclsh 8.4.2. The
    default library path is very UNIX like (e.g
    /usr/lib, etc.). Is there a way to configure
    the Amiga port to use gg:lib as the library
    path?

    I've added gg:lib to the libs assign.

    I've tried creating a LD_LIBRARY_PATH
    and a TCLHOME environment variable.

    I'm running OS 3.9 on an Amithlon machine.

    If anyone has other ideas, I would be very
    grateful.

    See below for the runtime log generated while
    attempting to run the sample tool: "index.tcl".

    Thank you.

    Mike

    5.Applications:GG/lib> tclsh8.4 Applications:Downloads/TclTk-8.4.2/tools/index.tcl
    application-specific initialization failed: Can't find a usable init.tcl in the following directories:
        /usr/lib/tcl8.4 /lib/tcl8.4 /library /usr/lib/tcl8.4

    This probably means that Tcl wasn't installed properly.

    Can't find a usable init.tcl in the following directories:
        /usr/lib/tcl8.4 /lib/tcl8.4 /library /usr/lib/tcl8.4

    This probably means that Tcl wasn't installed properly.

        while executing
    "error $msg"
        (procedure "tclInit" line 42)
        invoked from within
    "tclInit"
    5.Applications:GG/lib>

     
    • Diego Casorran

      Diego Casorran - 2003-05-06

      have you extracted install.tar properly into GG: ?

      cp somepath/install.tar /gg/install.tar
      tar xvf ./install.tar

      ....

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks